summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
commit25e003727af97ee93b1663d2df72b76fc4975dc9 (patch)
treea40811a107ace33142d3229769f28277ee050fb8 /debian/rules
parentAdding upstream version 2.1.1. (diff)
downloadmdds-25e003727af97ee93b1663d2df72b76fc4975dc9.tar.xz
mdds-25e003727af97ee93b1663d2df72b76fc4975dc9.zip
Adding debian version 2.1.1-2.debian/2.1.1-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..aff236e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_autoreconf ./autogen.sh
+ dh_auto_configure --buildsystem=autoconf
+
+override_dh_auto_build:
+ cd doc && doxygen doxygen.conf
+
+override_dh_auto_test:
+ifneq (nocheck,$(DEB_BUILD_OPTIONS))
+ $(MAKE) check
+endif
+
+override_dh_clean:
+ dh_autoreconf_clean
+ifneq (nocheck,$(DEB_BUILD_OPTIONS))
+ rm -rf obj
+endif
+ rm -f Makefile config.status config.log
+ rm -f VERSION example/Makefile misc/mdds.spec misc/mdds.pc
+ rm -rf doc/_doxygen
+
+ dh_clean