summaryrefslogtreecommitdiffstats
path: root/debian/tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
commit25e003727af97ee93b1663d2df72b76fc4975dc9 (patch)
treea40811a107ace33142d3229769f28277ee050fb8 /debian/tests
parentAdding upstream version 2.1.1. (diff)
downloadmdds-25e003727af97ee93b1663d2df72b76fc4975dc9.tar.xz
mdds-25e003727af97ee93b1663d2df72b76fc4975dc9.zip
Adding debian version 2.1.1-2.debian/2.1.1-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/tests')
-rw-r--r--debian/tests/control3
-rwxr-xr-xdebian/tests/make-check19
-rw-r--r--debian/tests/patches/system-includes.diff35
3 files changed, 57 insertions, 0 deletions
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..7ace532
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Tests: make-check
+Depends: @builddeps@, libmdds-dev, dh-autoreconf, pkg-config
+Restrictions: allow-stderr
diff --git a/debian/tests/make-check b/debian/tests/make-check
new file mode 100755
index 0000000..2c6de92
--- /dev/null
+++ b/debian/tests/make-check
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+set -e
+set -E
+
+function cleanup() {
+ dh_autoreconf_clean
+ patch -p1 -R < debian/tests/patches/system-includes.diff
+}
+
+trap cleanup ERR
+
+patch -p1 < debian/tests/patches/system-includes.diff
+dh_autoreconf
+aclocal && automake
+dh_auto_configure
+make -C example check
+
+cleanup
diff --git a/debian/tests/patches/system-includes.diff b/debian/tests/patches/system-includes.diff
new file mode 100644
index 0000000..b26ccc7
--- /dev/null
+++ b/debian/tests/patches/system-includes.diff
@@ -0,0 +1,35 @@
+diff --git a/example/Makefile.am b/example/Makefile.am
+index 877a5e2..3930e10 100644
+--- a/example/Makefile.am
++++ b/example/Makefile.am
+@@ -1,5 +1,5 @@
+
+-AM_CPPFLAGS = -I$(top_srcdir)/include -DNDEBUG
++AM_CPPFLAGS = $(shell pkg-config --cflags mdds-2.1) -DNDEBUG
+
+ EXTRA_PROGRAMS = \
+ flat-segment-tree \
+diff --git a/configure.ac b/configure.ac
+index f2ad3e8..588db4e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,7 +13,6 @@ PACKAGE_TARNAME=AC_PACKAGE_TARNAME
+ AC_SUBST(PACKAGE_TARNAME)
+
+ OBJDIR=obj
+-INCDIR=include
+ MISCDIR=misc
+ QUICKCHECKDIR=quickcheck
+ AC_SUBST(OBJDIR)
+@@ -134,11 +133,6 @@ AC_SUBST(CXXFLAGS_UNITTESTS)
+
+ AC_CONFIG_FILES([
+ Makefile
+-include/Makefile
+-include/mdds/Makefile
+-include/mdds/multi_type_vector/Makefile
+-include/mdds/multi_type_vector/aos/Makefile
+-include/mdds/multi_type_vector/soa/Makefile
+ example/Makefile
+ test/Makefile
+ test/gdb/Makefile