summaryrefslogtreecommitdiffstats
path: root/test/segment_tree/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:46:17 +0000
commit85adc697d2ec2a379ce6d721f0419ae5df3abdb6 (patch)
tree265f329bc4544c6f11a27ac3fd6022f593a10c11 /test/segment_tree/Makefile.am
parentInitial commit. (diff)
downloadmdds-upstream.tar.xz
mdds-upstream.zip
Adding upstream version 2.1.1.upstream/2.1.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/segment_tree/Makefile.am')
-rw-r--r--test/segment_tree/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/segment_tree/Makefile.am b/test/segment_tree/Makefile.am
new file mode 100644
index 0000000..b4927a7
--- /dev/null
+++ b/test/segment_tree/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/test/include \
+ $(CXXFLAGS_UNITTESTS)
+
+check_PROGRAMS = test-main
+
+test_main_SOURCES = \
+ test_main.cpp \
+ $(top_srcdir)/test/test_global.cpp
+
+TESTS = test-main
+
+@VALGRIND_CHECK_RULES@