summaryrefslogtreecommitdiffstats
path: root/test/gdb/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/gdb/src/Makefile.am')
-rw-r--r--test/gdb/src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/gdb/src/Makefile.am b/test/gdb/src/Makefile.am
new file mode 100644
index 0000000..5088c6e
--- /dev/null
+++ b/test/gdb/src/Makefile.am
@@ -0,0 +1,16 @@
+CXXFLAGS += -O0 -ggdb2
+
+check_PROGRAMS = test
+
+test_CPPFLAGS = -I$(top_srcdir)/include
+
+test_SOURCES = \
+ flat_segment_tree.cpp \
+ multi_type_matrix.cpp \
+ multi_type_vector.cpp \
+ point_quad_tree.cpp \
+ rtree.cpp \
+ segment_tree.cpp \
+ sorted_string_map.cpp \
+ test.cpp \
+ trie_map.cpp