summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 17:03:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 17:03:17 +0000
commit24e2dd0018f3f8de28ae29ccc8a17412910c4443 (patch)
treea3773d80a2f7ccc69dd546a7309aca6a6f35a970
parentAdding debian version 1.5.0-1. (diff)
downloadmmdebstrap-debian.tar.xz
mmdebstrap-debian.zip
Adding debian version 1.5.0-2.debian/1.5.0-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0001-Revert-attempt-diagnosing-skip-tar-in-mknod-failure-.patch61
-rw-r--r--debian/patches/installed_size.patch11
-rw-r--r--debian/patches/series2
-rw-r--r--debian/tests/control1
5 files changed, 83 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a842390..ca7846e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mmdebstrap (1.5.0-2) unstable; urgency=medium
+
+ * add debian/patches/installed_size.patch
+ * debian/tests/control: add uuid-runtime to Depends
+ * revert auditd for skip-tar-in-mknod
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Wed, 15 May 2024 07:04:26 +0200
+
mmdebstrap (1.5.0-1) unstable; urgency=medium
* New upstream version 1.5.0
diff --git a/debian/patches/0001-Revert-attempt-diagnosing-skip-tar-in-mknod-failure-.patch b/debian/patches/0001-Revert-attempt-diagnosing-skip-tar-in-mknod-failure-.patch
new file mode 100644
index 0000000..4b0b43c
--- /dev/null
+++ b/debian/patches/0001-Revert-attempt-diagnosing-skip-tar-in-mknod-failure-.patch
@@ -0,0 +1,61 @@
+From 84f80673f40a92b9b5d6c3b5274f25e755b7ff22 Mon Sep 17 00:00:00 2001
+From: Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
+Date: Wed, 15 May 2024 00:23:56 +0200
+Subject: [PATCH] Revert "attempt diagnosing skip-tar-in-mknod failure 'file
+ changed as we read it' using auditd"
+
+This reverts commit 726fc38d1d9e7771e3fbacc218154bc08b364da9.
+---
+ coverage.txt | 2 +-
+ make_mirror.sh | 1 -
+ tests/skip-tar-in-mknod | 5 ++---
+ 3 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/coverage.txt b/coverage.txt
+index dde5b33..c040b8b 100644
+--- a/coverage.txt
++++ b/coverage.txt
+@@ -433,4 +433,4 @@ Test: skip-output-mknod
+ Modes: root unshare
+
+ Test: skip-tar-in-mknod
+-Modes: root
++Modes: unshare
+diff --git a/make_mirror.sh b/make_mirror.sh
+index 3f8aae4..442b3ce 100755
+--- a/make_mirror.sh
++++ b/make_mirror.sh
+@@ -457,7 +457,6 @@ if [ "$HAVE_QEMU" = "yes" ]; then
+ if [ ! -e ./mmdebstrap ]; then
+ pkgs="$pkgs,mmdebstrap"
+ fi
+- pkgs="$pkgs,auditd"
+ arches=$HOSTARCH
+ if [ "$RUN_MA_SAME_TESTS" = "yes" ]; then
+ case "$HOSTARCH" in
+diff --git a/tests/skip-tar-in-mknod b/tests/skip-tar-in-mknod
+index cc18977..eb3027a 100644
+--- a/tests/skip-tar-in-mknod
++++ b/tests/skip-tar-in-mknod
+@@ -3,7 +3,7 @@ set -eu
+ export LC_ALL=C.UTF-8
+ export SOURCE_DATE_EPOCH={{ SOURCE_DATE_EPOCH }}
+
+-#[ {{ MODE }} = "unshare" ]
++[ {{ MODE }} = "unshare" ]
+
+ trap "rm -f /tmp/debian-chroot.tar" EXIT INT TERM
+
+@@ -22,8 +22,7 @@ fi
+ $prefix {{ CMD }} --mode={{ MODE }} --variant=custom \
+ --skip=update,setup,cleanup,tar-in/mknod \
+ --setup-hook='tar-in ./cache/mmdebstrap-{{ DIST }}-apt.tar /' \
+- --setup-hook='/sbin/auditctl -w "$1" -p wxa -k mykey' \
+- '' /tmp/debian-chroot.tar || /sbin/ausearch --format text -k mykey
++ '' /tmp/debian-chroot.tar
+
+ cmp ./cache/mmdebstrap-{{ DIST }}-apt.tar /tmp/debian-chroot.tar \
+ || diffoscope ./cache/mmdebstrap-{{ DIST }}-apt.tar /tmp/debian-chroot.tar
+--
+2.39.2
+
diff --git a/debian/patches/installed_size.patch b/debian/patches/installed_size.patch
new file mode 100644
index 0000000..9a3b860
--- /dev/null
+++ b/debian/patches/installed_size.patch
@@ -0,0 +1,11 @@
+--- a/mmdebstrap
++++ b/mmdebstrap
+@@ -4453,7 +4453,7 @@ sub approx_disk_usage {
+ find({ wanted => $scan_installed_size, no_chdir => 1 }, $directory);
+
+ # because the above is only a heuristic we add 10% extra for good measure
+- return int($installed_size * 1.1);
++ return int($installed_size * 1.2);
+ }
+
+ sub main() {
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d31b9c3
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+installed_size.patch
+0001-Revert-attempt-diagnosing-skip-tar-in-mknod-failure-.patch
diff --git a/debian/tests/control b/debian/tests/control
index 69f90a0..958a144 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -26,6 +26,7 @@ Depends:
squashfs-tools-ng,
sudo,
uidmap,
+ uuid-runtime,
Restrictions: needs-root, allow-stderr, skippable
# add a manual trigger on those packages that in the past broke this test