summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control3
-rw-r--r--debian/patches/0001-tests-debootstrap-dump-tmpdir-debootstrap-debootstra.patch31
-rw-r--r--debian/patches/series1
4 files changed, 42 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d8e4c39..7d6dc6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mmdebstrap (1.5.1-4) unstable; urgency=medium
+
+ * add patch to find out cause of debootstrap failure on s390x
+ * debian/control: add Suggests on e2fsprogs and libarchive13 for ext4 format
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Wed, 12 Jun 2024 14:46:30 +0200
+
mmdebstrap (1.5.1-3~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/control b/debian/control
index 54e8b0c..fcc6570 100644
--- a/debian/control
+++ b/debian/control
@@ -66,6 +66,9 @@ Suggests:
dpkg-dev,
# --format=ext2
genext2fs,
+# --format=ext4
+ e2fsprogs,
+ libarchive13,
# Generation of man page from source code
perl-doc,
# for cross platform builds such as building arm64 on amd64
diff --git a/debian/patches/0001-tests-debootstrap-dump-tmpdir-debootstrap-debootstra.patch b/debian/patches/0001-tests-debootstrap-dump-tmpdir-debootstrap-debootstra.patch
new file mode 100644
index 0000000..d80e282
--- /dev/null
+++ b/debian/patches/0001-tests-debootstrap-dump-tmpdir-debootstrap-debootstra.patch
@@ -0,0 +1,31 @@
+From d0c30c70bd7de22a7fc1f281346e7915dfb3d057 Mon Sep 17 00:00:00 2001
+From: Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
+Date: Wed, 12 Jun 2024 11:41:17 +0200
+Subject: [PATCH] tests/debootstrap: dump $tmpdir/debootstrap/debootstrap.log
+ on failure
+
+---
+ tests/debootstrap | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/tests/debootstrap b/tests/debootstrap
+index 63c217d..9e1709e 100644
+--- a/tests/debootstrap
++++ b/tests/debootstrap
+@@ -5,6 +5,12 @@ export SOURCE_DATE_EPOCH={{ SOURCE_DATE_EPOCH }}
+
+ tmpdir="$(mktemp -d)"
+ chmod 755 "$tmpdir"
+-debootstrap "$([ "{{ DIST }}" = oldstable ] && echo --no-merged-usr || echo --merged-usr)" --variant={{ VARIANT }} {{ DIST }} "$tmpdir" {{ MIRROR }}
++ret=0
++debootstrap "$([ "{{ DIST }}" = oldstable ] && echo --no-merged-usr || echo --merged-usr)" --variant={{ VARIANT }} {{ DIST }} "$tmpdir" {{ MIRROR }} || ret=$?
++if [ "$ret" -ne 0 ]; then
++ echo "E: debootstrap failed, dumping $tmpdir/debootstrap/debootstrap.log"
++ cat "$tmpdir/debootstrap/debootstrap.log"
++ exit 1
++fi
+ tar --sort=name --mtime=@$SOURCE_DATE_EPOCH --clamp-mtime --numeric-owner --one-file-system --xattrs -C "$tmpdir" -c . > "./cache/debian-{{ DIST }}-{{ VARIANT }}.tar"
+ rm -r "$tmpdir"
+--
+2.39.2
+
diff --git a/debian/patches/series b/debian/patches/series
index f54042e..fc211c6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
0001-tests-base-files-now-ships-merged-usr-symlinks.patch
0001-tests-empty-sources.list-only-write-out-etc-apt-sour.patch
+0001-tests-debootstrap-dump-tmpdir-debootstrap-debootstra.patch