summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/02_check_icmp_links30
-rw-r--r--debian/patches/03_epn8
-rw-r--r--debian/patches/series4
3 files changed, 42 insertions, 0 deletions
diff --git a/debian/patches/02_check_icmp_links b/debian/patches/02_check_icmp_links
new file mode 100644
index 0000000..591683c
--- /dev/null
+++ b/debian/patches/02_check_icmp_links
@@ -0,0 +1,30 @@
+## 02_check_icmp_links by Jan Wagner <waja@cyconet.org>
+##
+## DP: Create symlinks for check_icmp to provide default values for some situations
+
+diff -urNad nagios-plugins-1.4.14~/plugins-root/Makefile.am nagios-plugins-1.4.14/plugins-root/Makefile.am
+--- nagios-plugins-1.4.14~/plugins-root/Makefile.am 2008-11-30 22:23:18.000000000 +0100
++++ nagios-plugins-1.4.14/plugins-root/Makefile.am 2010-01-10 20:39:03.000000000 +0100
+@@ -71,7 +71,8 @@
+ else \
+ echo "WARNING: insufficient access; not installing setuid plugins"; \
+ echo "NOTE: to install setuid plugins, run 'make install-root' as root"; \
+- fi
++ fi ; \
++ if [ -x $(DESTDIR)$(libexecdir)/check_icmp ] ; then rm -f $(DESTDIR)$(libexecdir)/check_host $(DESTDIR)$(libexecdir)/check_rta_multi ; ln -s check_icmp $(DESTDIR)$(libexecdir)/check_host ; ln -s check_icmp $(DESTDIR)$(libexecdir)/check_rta_multi ; fi
+
+ # /* Author Coreutils team sub-citation */
+
+diff -urNad nagios-plugins-1.4.14~/plugins-root/Makefile.in nagios-plugins-1.4.14/plugins-root/Makefile.in
+--- nagios-plugins-1.4.14~/plugins-root/Makefile.in 2009-09-16 10:37:59.000000000 +0200
++++ nagios-plugins-1.4.14/plugins-root/Makefile.in 2010-01-10 20:39:13.000000000 +0100
+@@ -1162,7 +1162,8 @@
+ else \
+ echo "WARNING: insufficient access; not installing setuid plugins"; \
+ echo "NOTE: to install setuid plugins, run 'make install-root' as root"; \
+- fi
++ fi ; \
++ if [ -x $(DESTDIR)$(libexecdir)/check_icmp ] ; then rm -f $(DESTDIR)$(libexecdir)/check_host $(DESTDIR)$(libexecdir)/check_rta_multi ; ln -s check_icmp $(DESTDIR)$(libexecdir)/check_host ; ln -s check_icmp $(DESTDIR)$(libexecdir)/check_rta_multi ; fi
+
+ clean-local:
+ rm -f NP-VERSION-FILE
diff --git a/debian/patches/03_epn b/debian/patches/03_epn
new file mode 100644
index 0000000..5ee4062
--- /dev/null
+++ b/debian/patches/03_epn
@@ -0,0 +1,8 @@
+--- a/plugins-scripts/check_disk_smb.pl
++++ b/plugins-scripts/check_disk_smb.pl
+@@ -1,4 +1,5 @@
+ #!@PERL@ -w
++# nagios: -epn
+ #
+ #
+ # check_disk.pl <host> <share> <user> <pass> [warn] [critical] [port]
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1cf9eea
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+02_check_icmp_links
+03_epn
+# commited upstream
+# feature patches