summaryrefslogtreecommitdiffstats
path: root/ci
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:36:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:36:56 +0000
commit51de1d8436100f725f3576aefa24a2bd2057bc28 (patch)
treec6d1d5264b6d40a8d7ca34129f36b7d61e188af3 /ci
parentInitial commit. (diff)
downloadmpv-51de1d8436100f725f3576aefa24a2bd2057bc28.tar.xz
mpv-51de1d8436100f725f3576aefa24a2bd2057bc28.zip
Adding upstream version 0.37.0.upstream/0.37.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ci')
-rwxr-xr-xci/build-freebsd.sh29
-rwxr-xr-xci/build-macos.sh22
-rwxr-xr-xci/build-mingw64.sh306
-rwxr-xr-xci/build-msys2.sh39
-rwxr-xr-xci/build-tumbleweed.sh20
-rwxr-xr-xci/lint-commit-msg.py116
6 files changed, 532 insertions, 0 deletions
diff --git a/ci/build-freebsd.sh b/ci/build-freebsd.sh
new file mode 100755
index 0000000..bc68a25
--- /dev/null
+++ b/ci/build-freebsd.sh
@@ -0,0 +1,29 @@
+#!/bin/sh
+set -e
+
+export CFLAGS="$CFLAGS -isystem/usr/local/include"
+export CXXFLAGS="$CXXFLAGS -isystem/usr/local/include"
+export LDFLAGS="$LDFLAGS -L/usr/local/lib"
+
+meson setup build \
+ --werror \
+ -Dlibplacebo:werror=false \
+ -Dc_args="-Wno-error=deprecated -Wno-error=deprecated-declarations" \
+ -Diconv=disabled \
+ -Dlibmpv=true \
+ -Dlua=enabled \
+ -Degl-drm=enabled \
+ -Dopenal=enabled \
+ -Dsndio=enabled \
+ -Dtests=true \
+ -Dvdpau=enabled \
+ -Dvulkan=enabled \
+ -Doss-audio=enabled \
+ $(pkg info -q v4l_compat && echo -Ddvbin=enabled) \
+ $(pkg info -q libdvdnav && echo -Ddvdnav=enabled) \
+ $(pkg info -q libcdio-paranoia && echo -Dcdda=enabled) \
+ $(pkg info -q pipewire && echo -Dpipewire=enabled) \
+ $NULL
+
+meson compile -C build
+./build/mpv -v --no-config
diff --git a/ci/build-macos.sh b/ci/build-macos.sh
new file mode 100755
index 0000000..14b3a1b
--- /dev/null
+++ b/ci/build-macos.sh
@@ -0,0 +1,22 @@
+#!/usr/bin/env bash
+
+set -e
+
+FFMPEG_SYSROOT="${HOME}/deps/sysroot"
+MPV_INSTALL_PREFIX="${HOME}/out/mpv"
+MPV_VARIANT="${TRAVIS_OS_NAME}"
+
+if [[ -d "./build/${MPV_VARIANT}" ]] ; then
+ rm -rf "./build/${MPV_VARIANT}"
+fi
+
+PKG_CONFIG_PATH="${FFMPEG_SYSROOT}/lib/pkgconfig/" CC="${CC}" CXX="${CXX}" \
+meson setup build \
+ -Dprefix="${MPV_INSTALL_PREFIX}" \
+ -D{libmpv,tests}=true \
+ -D{gl,iconv,lcms2,lua,jpeg,plain-gl,zlib}=enabled \
+ -D{cocoa,coreaudio,gl-cocoa,macos-cocoa-cb,macos-touchbar,videotoolbox-gl}=enabled
+
+meson compile -C build -j4
+meson install -C build
+./build/mpv -v --no-config
diff --git a/ci/build-mingw64.sh b/ci/build-mingw64.sh
new file mode 100755
index 0000000..adca649
--- /dev/null
+++ b/ci/build-mingw64.sh
@@ -0,0 +1,306 @@
+#!/bin/bash -e
+
+prefix_dir=$PWD/mingw_prefix
+mkdir -p "$prefix_dir"
+ln -snf . "$prefix_dir/usr"
+ln -snf . "$prefix_dir/local"
+
+wget="wget -nc --progress=bar:force"
+gitclone="git clone --depth=1 --recursive"
+
+# -posix is Ubuntu's variant with pthreads support
+export CC=$TARGET-gcc-posix
+export CXX=$TARGET-g++-posix
+export AR=$TARGET-ar
+export NM=$TARGET-nm
+export RANLIB=$TARGET-ranlib
+
+export CFLAGS="-O2 -pipe -Wall -D_FORTIFY_SOURCE=2"
+export LDFLAGS="-fstack-protector-strong"
+
+# anything that uses pkg-config
+export PKG_CONFIG_SYSROOT_DIR="$prefix_dir"
+export PKG_CONFIG_LIBDIR="$PKG_CONFIG_SYSROOT_DIR/lib/pkgconfig"
+
+# autotools(-like)
+commonflags="--disable-static --enable-shared"
+
+# meson
+fam=x86_64
+[[ "$TARGET" == "i686-"* ]] && fam=x86
+cat >"$prefix_dir/crossfile" <<EOF
+[built-in options]
+buildtype = 'release'
+wrap_mode = 'nodownload'
+[binaries]
+c = ['ccache', '${CC}']
+cpp = ['ccache', '${CXX}']
+ar = '${AR}'
+strip = '${TARGET}-strip'
+pkgconfig = 'pkg-config'
+windres = '${TARGET}-windres'
+dlltool = '${TARGET}-dlltool'
+[host_machine]
+system = 'windows'
+cpu_family = '${fam}'
+cpu = '${TARGET%%-*}'
+endian = 'little'
+EOF
+
+# CMake
+cmake_args=(
+ -Wno-dev
+ -DCMAKE_SYSTEM_NAME=Windows
+ -DCMAKE_FIND_ROOT_PATH="$PKG_CONFIG_SYSROOT_DIR"
+ -DCMAKE_RC_COMPILER="${TARGET}-windres"
+ -DCMAKE_BUILD_TYPE=Release
+)
+
+export CC="ccache $CC"
+export CXX="ccache $CXX"
+
+function builddir {
+ [ -d "$1/builddir" ] && rm -rf "$1/builddir"
+ mkdir -p "$1/builddir"
+ pushd "$1/builddir"
+}
+
+function makeplusinstall {
+ if [ -f build.ninja ]; then
+ ninja
+ DESTDIR="$prefix_dir" ninja install
+ else
+ make -j$(nproc)
+ make DESTDIR="$prefix_dir" install
+ fi
+}
+
+function gettar {
+ local name="${1##*/}"
+ [ -d "${name%%.*}" ] && return 0
+ $wget "$1"
+ tar -xaf "$name"
+}
+
+function build_if_missing {
+ local name=${1//-/_}
+ local mark_var=_${name}_mark
+ local mark_file=$prefix_dir/${!mark_var}
+ [ -e "$mark_file" ] && return 0
+ echo "::group::Building $1"
+ _$name
+ echo "::endgroup::"
+ if [ ! -e "$mark_file" ]; then
+ echo "Error: Build of $1 completed but $mark_file was not created."
+ return 2
+ fi
+}
+
+
+## mpv's dependencies
+
+_iconv () {
+ local ver=1.17
+ gettar "https://ftp.gnu.org/pub/gnu/libiconv/libiconv-${ver}.tar.gz"
+ builddir libiconv-${ver}
+ ../configure --host=$TARGET $commonflags
+ makeplusinstall
+ popd
+}
+_iconv_mark=lib/libiconv.dll.a
+
+_zlib () {
+ local ver=1.3
+ gettar "https://zlib.net/fossils/zlib-${ver}.tar.gz"
+ pushd zlib-${ver}
+ make -fwin32/Makefile.gcc clean
+ make -fwin32/Makefile.gcc PREFIX=$TARGET- CC="$CC" SHARED_MODE=1 \
+ DESTDIR="$prefix_dir" install \
+ BINARY_PATH=/bin INCLUDE_PATH=/include LIBRARY_PATH=/lib
+ popd
+}
+_zlib_mark=lib/libz.dll.a
+
+_ffmpeg () {
+ [ -d ffmpeg ] || $gitclone https://github.com/FFmpeg/FFmpeg.git ffmpeg
+ builddir ffmpeg
+ local args=(
+ --pkg-config=pkg-config --target-os=mingw32
+ --enable-cross-compile --cross-prefix=$TARGET- --arch=${TARGET%%-*}
+ --cc="$CC" --cxx="$CXX" $commonflags
+ --disable-{doc,programs,muxers,encoders}
+ --enable-encoder=mjpeg,png
+ )
+ pkg-config vulkan && args+=(--enable-vulkan --enable-libshaderc)
+ ../configure "${args[@]}"
+ makeplusinstall
+ popd
+}
+_ffmpeg_mark=lib/libavcodec.dll.a
+
+_shaderc () {
+ if [ ! -d shaderc ]; then
+ $gitclone https://github.com/google/shaderc.git
+ (cd shaderc && ./utils/git-sync-deps)
+ fi
+ builddir shaderc
+ cmake .. "${cmake_args[@]}" \
+ -DBUILD_SHARED_LIBS=OFF -DSHADERC_SKIP_TESTS=ON
+ makeplusinstall
+ popd
+}
+_shaderc_mark=lib/libshaderc_shared.dll.a
+
+_spirv_cross () {
+ [ -d SPIRV-Cross ] || $gitclone https://github.com/KhronosGroup/SPIRV-Cross
+ builddir SPIRV-Cross
+ cmake .. "${cmake_args[@]}" \
+ -DSPIRV_CROSS_SHARED=ON -DSPIRV_CROSS_{CLI,STATIC}=OFF
+ makeplusinstall
+ popd
+}
+_spirv_cross_mark=lib/libspirv-cross-c-shared.dll.a
+
+_vulkan_headers () {
+ [ -d Vulkan-Headers ] || $gitclone https://github.com/KhronosGroup/Vulkan-Headers -b v1.3.266
+ builddir Vulkan-Headers
+ cmake .. "${cmake_args[@]}"
+ makeplusinstall
+ popd
+}
+_vulkan_headers_mark=include/vulkan/vulkan.h
+
+_vulkan_loader () {
+ [ -d Vulkan-Loader ] || $gitclone https://github.com/KhronosGroup/Vulkan-Loader -b v1.3.266
+ builddir Vulkan-Loader
+ cmake .. "${cmake_args[@]}" \
+ -DENABLE_WERROR=OFF
+ makeplusinstall
+ popd
+}
+_vulkan_loader_mark=lib/libvulkan-1.dll.a
+
+_libplacebo () {
+ [ -d libplacebo ] || $gitclone https://code.videolan.org/videolan/libplacebo.git
+ builddir libplacebo
+ meson setup .. --cross-file "$prefix_dir/crossfile" \
+ -Ddemos=false -D{opengl,d3d11}=enabled
+ makeplusinstall
+ popd
+}
+_libplacebo_mark=lib/libplacebo.dll.a
+
+_freetype () {
+ local ver=2.13.1
+ gettar "https://mirror.netcologne.de/savannah/freetype/freetype-${ver}.tar.xz"
+ builddir freetype-${ver}
+ meson setup .. --cross-file "$prefix_dir/crossfile"
+ makeplusinstall
+ popd
+}
+_freetype_mark=lib/libfreetype.dll.a
+
+_fribidi () {
+ local ver=1.0.13
+ gettar "https://github.com/fribidi/fribidi/releases/download/v${ver}/fribidi-${ver}.tar.xz"
+ builddir fribidi-${ver}
+ meson setup .. --cross-file "$prefix_dir/crossfile" \
+ -D{tests,docs}=false
+ makeplusinstall
+ popd
+}
+_fribidi_mark=lib/libfribidi.dll.a
+
+_harfbuzz () {
+ local ver=8.1.1
+ gettar "https://github.com/harfbuzz/harfbuzz/releases/download/${ver}/harfbuzz-${ver}.tar.xz"
+ builddir harfbuzz-${ver}
+ meson setup .. --cross-file "$prefix_dir/crossfile" \
+ -Dtests=disabled
+ makeplusinstall
+ popd
+}
+_harfbuzz_mark=lib/libharfbuzz.dll.a
+
+_libass () {
+ [ -d libass ] || $gitclone https://github.com/libass/libass.git
+ builddir libass
+ [ -f ../configure ] || (cd .. && ./autogen.sh)
+ ../configure --host=$TARGET $commonflags
+ makeplusinstall
+ popd
+}
+_libass_mark=lib/libass.dll.a
+
+_luajit () {
+ [ -d LuaJIT ] || $gitclone https://github.com/LuaJIT/LuaJIT.git
+ pushd LuaJIT
+ local hostcc="ccache cc"
+ local flags=
+ [[ "$TARGET" == "i686-"* ]] && { hostcc="$hostcc -m32"; flags=XCFLAGS=-DLUAJIT_NO_UNWIND; }
+ make TARGET_SYS=Windows clean
+ make TARGET_SYS=Windows HOST_CC="$hostcc" CROSS="ccache $TARGET-" \
+ BUILDMODE=static $flags amalg
+ make DESTDIR="$prefix_dir" INSTALL_DEP= FILE_T=luajit.exe install
+ popd
+}
+_luajit_mark=lib/libluajit-5.1.a
+
+for x in iconv zlib shaderc spirv-cross; do
+ build_if_missing $x
+done
+if [[ "$TARGET" != "i686-"* ]]; then
+ build_if_missing vulkan-headers
+ build_if_missing vulkan-loader
+fi
+for x in ffmpeg libplacebo freetype fribidi harfbuzz libass luajit; do
+ build_if_missing $x
+done
+
+## mpv
+
+[ -z "$1" ] && exit 0
+
+CFLAGS+=" -I'$prefix_dir/include'"
+LDFLAGS+=" -L'$prefix_dir/lib'"
+export CFLAGS LDFLAGS
+build=mingw_build
+rm -rf $build
+
+meson setup $build --cross-file "$prefix_dir/crossfile" \
+ --werror \
+ -Dlibplacebo:werror=false \
+ -Dc_args="-Wno-error=deprecated -Wno-error=deprecated-declarations" \
+ --buildtype debugoptimized \
+ -Dlibmpv=true -Dlua=luajit \
+ -D{shaderc,spirv-cross,d3d11}=enabled
+
+meson compile -C $build
+
+if [ "$2" = pack ]; then
+ mkdir -p artifact/tmp
+ echo "Copying:"
+ cp -pv $build/player/mpv.com $build/mpv.exe artifact/
+ # copy everything we can get our hands on
+ cp -p "$prefix_dir/bin/"*.dll artifact/tmp/
+ shopt -s nullglob
+ for file in /usr/lib/gcc/$TARGET/*-posix/*.dll /usr/$TARGET/lib/*.dll; do
+ cp -p "$file" artifact/tmp/
+ done
+ # pick DLLs we need
+ pushd artifact/tmp
+ dlls=(
+ libgcc_*.dll lib{ssp,stdc++,winpthread}-[0-9]*.dll # compiler runtime
+ av*.dll sw*.dll lib{ass,freetype,fribidi,harfbuzz,iconv,placebo}-[0-9]*.dll
+ lib{shaderc_shared,spirv-cross-c-shared}.dll zlib1.dll
+ # note: vulkan-1.dll is not here since drivers provide it
+ )
+ mv -v "${dlls[@]}" ..
+ popd
+
+ echo "Archiving:"
+ pushd artifact
+ rm -rf tmp
+ zip -9r "../mpv-git-$(date +%F)-$(git rev-parse --short HEAD)-${TARGET%%-*}.zip" -- *
+ popd
+fi
diff --git a/ci/build-msys2.sh b/ci/build-msys2.sh
new file mode 100755
index 0000000..d3e1ce9
--- /dev/null
+++ b/ci/build-msys2.sh
@@ -0,0 +1,39 @@
+#!/bin/sh -e
+
+mkdir subprojects
+cat > subprojects/libplacebo.wrap <<EOF
+[wrap-git]
+url = https://code.videolan.org/videolan/libplacebo.git
+revision = v6.338.1
+depth = 1
+clone-recursive = true
+EOF
+
+meson setup build \
+ --werror \
+ -Dlibplacebo:werror=false \
+ -Dlibplacebo:demos=false \
+ -Dlibplacebo:default_library=static \
+ -Dc_args="-Wno-error=deprecated -Wno-error=deprecated-declarations" \
+ -D cdda=enabled \
+ -D d3d-hwaccel=enabled \
+ -D d3d11=enabled \
+ -D dvdnav=enabled \
+ -D egl-angle-lib=enabled \
+ -D egl-angle-win32=enabled \
+ -D jpeg=enabled \
+ -D lcms2=enabled \
+ -D libarchive=enabled \
+ -D libbluray=enabled \
+ -D libmpv=true \
+ -D lua=enabled \
+ -D pdf-build=enabled \
+ -D rubberband=enabled \
+ -D shaderc=enabled \
+ -D spirv-cross=enabled \
+ -D tests=true \
+ -D uchardet=enabled \
+ -D vapoursynth=enabled
+meson compile -C build
+cp ./build/player/mpv.com ./build
+./build/mpv.com -v --no-config
diff --git a/ci/build-tumbleweed.sh b/ci/build-tumbleweed.sh
new file mode 100755
index 0000000..03e8d1a
--- /dev/null
+++ b/ci/build-tumbleweed.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+set -e
+
+meson setup build \
+ --werror \
+ -Dlibplacebo:werror=false \
+ -Dc_args="-Wno-error=deprecated -Wno-error=deprecated-declarations" \
+ -Db_sanitize=address,undefined \
+ -Dcdda=enabled \
+ -Ddvbin=enabled \
+ -Ddvdnav=enabled \
+ -Dlibarchive=enabled \
+ -Dlibmpv=true \
+ -Dmanpage-build=enabled \
+ -Dpipewire=enabled \
+ -Dshaderc=enabled \
+ -Dtests=true \
+ -Dvulkan=enabled
+meson compile -C build
+./build/mpv -v --no-config
diff --git a/ci/lint-commit-msg.py b/ci/lint-commit-msg.py
new file mode 100755
index 0000000..4198ed4
--- /dev/null
+++ b/ci/lint-commit-msg.py
@@ -0,0 +1,116 @@
+#!/usr/bin/env python3
+import os, sys, json, subprocess, re
+
+def call(cmd) -> str:
+ sys.stdout.flush()
+ ret = subprocess.run(cmd, check=True, stdout=subprocess.PIPE, text=True)
+ return ret.stdout
+
+lint_rules = {}
+
+def lint_rule(description: str):
+ def f(func):
+ assert func.__name__ not in lint_rules.keys()
+ lint_rules[func.__name__] = (func, description)
+ return f
+
+def get_commit_range() -> str:
+ if len(sys.argv) > 1:
+ return sys.argv[1]
+ # https://github.com/actions/runner/issues/342#issuecomment-590670059
+ event_name = os.environ["GITHUB_EVENT_NAME"]
+ with open(os.environ["GITHUB_EVENT_PATH"], "rb") as f:
+ event = json.load(f)
+ if event_name == "push":
+ if event["created"] or event["forced"]:
+ print("Skipping logic on branch creation or force-push")
+ return None
+ return event["before"] + "..." + event["after"]
+ elif event_name == "pull_request":
+ return event["pull_request"]["base"]["sha"] + ".." + event["pull_request"]["head"]["sha"]
+
+def do_lint(commit_range: str) -> bool:
+ commits = call(["git", "log", "--pretty=format:%h %s", commit_range]).splitlines()
+ print(f"Linting {len(commits)} commit(s):")
+ any_failed = False
+ for commit in commits:
+ sha, _, _ = commit.partition(' ')
+ #print(commit)
+ body = call(["git", "show", "-s", "--format=%B", sha]).splitlines()
+ failed = []
+ if len(body) == 0:
+ failed.append("* Commit message must not be empty")
+ else:
+ for k, v in lint_rules.items():
+ if not v[0](body):
+ failed.append(f"* {v[1]} [{k}]")
+ if failed:
+ any_failed = True
+ print("-" * 40)
+ sys.stdout.flush()
+ subprocess.run(["git", "-P", "show", "-s", sha])
+ print("\nhas the following issues:")
+ print("\n".join(failed))
+ print("-" * 40)
+ return any_failed
+
+################################################################################
+
+NO_PREFIX_WHITELIST = r"^Revert \"(.*)\"|^Release [0-9]|^Update VERSION$"
+
+@lint_rule("Subject line must contain a prefix identifying the sub system")
+def subsystem_prefix(body):
+ if re.search(NO_PREFIX_WHITELIST, body[0]):
+ return True
+ m = re.search(r"^([^:]+):\s", body[0])
+ if not m:
+ return False
+ # a comma-separated list is okay
+ s = re.sub(r",\s+", "", m.group(1))
+ # but no spaces otherwise
+ return not " " in s
+
+@lint_rule("First word after : must be lower case")
+def description_lowercase(body):
+ if re.search(NO_PREFIX_WHITELIST, body[0]):
+ return True
+ # Allow all caps for acronyms and such
+ if re.search(r":\s[A-Z]{2,}\s", body[0]):
+ return True
+ return re.search(r":\s+[a-z0-9]", body[0])
+
+@lint_rule("Subject line must not end with a full stop")
+def no_dot(body):
+ return not body[0].rstrip().endswith('.')
+
+@lint_rule("There must be an empty line between subject and extended description")
+def empty_line(body):
+ return len(body) == 1 or body[1].strip() == ""
+
+# been seeing this one all over github lately, must be the webshits
+@lint_rule("Do not use 'conventional commits' style")
+def no_cc(body):
+ return not re.search(r"(?i)^(feat|fix|chore|refactor)[!:(]", body[0])
+
+@lint_rule("History must be linear, no merge commits")
+def no_merge(body):
+ return not body[0].startswith("Merge ")
+
+@lint_rule("Subject line should be shorter than 72 characters")
+def line_too_long(body):
+ revert = re.search(r"^Revert \"(.*)\"", body[0])
+ return True if revert else len(body[0]) <= 72
+
+@lint_rule("Prefix should not include C file extensions (use `vo_gpu: ...` not `vo_gpu.c: ...`)")
+def no_file_exts(body):
+ return not re.search(r"[a-z0-9]\.[ch]:\s", body[0])
+
+################################################################################
+
+if __name__ == "__main__":
+ commit_range = get_commit_range()
+ if commit_range is None:
+ exit(0)
+ print("Commit range:", commit_range)
+ any_failed = do_lint(commit_range)
+ exit(1 if any_failed else 0)