summaryrefslogtreecommitdiffstats
path: root/player/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:13:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:13:15 +0000
commitbff6c10f6909412899de6ab7c902f96080905550 (patch)
tree616d06233c652837e0d36657306ed0c157821a9a /player/meson.build
parentReleasing progress-linux version 0.37.0-1~progress7.99u1. (diff)
downloadmpv-bff6c10f6909412899de6ab7c902f96080905550.tar.xz
mpv-bff6c10f6909412899de6ab7c902f96080905550.zip
Merging upstream version 0.38.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'player/meson.build')
-rw-r--r--player/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/player/meson.build b/player/meson.build
index dc334b8..be1e812 100644
--- a/player/meson.build
+++ b/player/meson.build
@@ -1,10 +1,11 @@
subdir('javascript')
subdir('lua')
-# Meson doesn't allow having multiple build targets with the same name in the same file.
-# Just generate the com in here for windows builds.
-if win32 and get_option('cplayer')
+# Older versions of meson don't allow multiple build targets with the same name in the same
+# file. Generate it here for compatibility reasons for windows.
+if win32 and get_option('cplayer') and meson.version().version_compare('< 1.3.0')
wrapper_sources= '../osdep/win32-console-wrapper.c'
executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
name_suffix: 'com', install: true)
+ warning('mpv.com executable will be generated in the player subdirectory.')
endif