summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/common/meson.build b/common/meson.build
new file mode 100644
index 0000000..4bca5ea
--- /dev/null
+++ b/common/meson.build
@@ -0,0 +1,8 @@
+version_h = vcs_tag(
+ command: ['git', 'describe', '--always', '--tags', '--dirty'],
+ input: 'version.h.in',
+ output: 'version.h',
+ replace_string: '@VERSION@',
+)
+
+sources += version_h