summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0a90277
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/architecture.mk
+
+export DEB_BUILD_MAINT_OPTIONS := hardening=+all # #741439, #799738
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+ ARCH_CONFIGURE = -Ddvbin=enabled
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Dlibmpv=true \
+ -Dbuild-date=false \
+ -Dcdda=enabled \
+ -Ddvdnav=enabled \
+ -Dsdl2=enabled \
+ -Dsndio=disabled \
+ $(ARCH_CONFIGURE)
+
+execute_after_dh_auto_install:
+ mv debian/tmp/usr/share/zsh/site-functions debian/tmp/usr/share/zsh/vendor-completions
+
+override_dh_installchangelogs:
+ dh_installchangelogs RELEASE_NOTES