summaryrefslogtreecommitdiffstats
path: root/diagrams/docs/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /diagrams/docs/Makefile
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'diagrams/docs/Makefile')
-rw-r--r--diagrams/docs/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/diagrams/docs/Makefile b/diagrams/docs/Makefile
new file mode 100644
index 00000000..0ec11169
--- /dev/null
+++ b/diagrams/docs/Makefile
@@ -0,0 +1,18 @@
+DRAWIO ?= /opt/drawio/drawio
+DRAWIO_FLAGS = --export --format svg --transparent --embed-svg-images
+
+SOURCES := $(wildcard *.drawio)
+TARGETS := $(patsubst %.drawio,%.svg,$(SOURCES))
+
+.PHONY:
+all: svg
+
+.PHONY:
+svg: $(TARGETS)
+
+.PHONY:
+clean:
+ rm $(TARGETS)
+
+$(TARGETS): %.svg: %.drawio
+ $(DRAWIO) $(DRAWIO_FLAGS) --output $@ $<