summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/cfl/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/lib/cfl/src/CMakeLists.txt
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/cfl/src/CMakeLists.txt')
-rw-r--r--fluent-bit/lib/cfl/src/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/fluent-bit/lib/cfl/src/CMakeLists.txt b/fluent-bit/lib/cfl/src/CMakeLists.txt
new file mode 100644
index 00000000..53f2a620
--- /dev/null
+++ b/fluent-bit/lib/cfl/src/CMakeLists.txt
@@ -0,0 +1,29 @@
+set(src
+ cfl.c
+ cfl_log.c
+ cfl_sds.c
+ cfl_time.c
+ cfl_kv.c
+ cfl_kvlist.c
+ cfl_array.c
+ cfl_variant.c
+ cfl_checksum.c
+ )
+
+# Static Library
+add_library(cfl-static STATIC ${src})
+target_link_libraries(cfl-static xxhash)
+
+# Install Library
+if(MSVC)
+ # Rename the output for Windows environment to avoid naming issues
+ set_target_properties(cfl-static PROPERTIES OUTPUT_NAME libcfl)
+else()
+ set_target_properties(cfl-static PROPERTIES OUTPUT_NAME cfl)
+endif(MSVC)
+
+install(TARGETS cfl-static
+ RUNTIME DESTINATION ${CFL_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CFL_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CFL_INSTALL_LIBDIR}
+ COMPONENT library)