summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/fluent-otel-proto/examples
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/lib/fluent-otel-proto/examples
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/fluent-otel-proto/examples')
-rw-r--r--fluent-bit/lib/fluent-otel-proto/examples/CMakeLists.txt7
-rw-r--r--fluent-bit/lib/fluent-otel-proto/examples/test-api.c29
2 files changed, 36 insertions, 0 deletions
diff --git a/fluent-bit/lib/fluent-otel-proto/examples/CMakeLists.txt b/fluent-bit/lib/fluent-otel-proto/examples/CMakeLists.txt
new file mode 100644
index 00000000..bd0ecab4
--- /dev/null
+++ b/fluent-bit/lib/fluent-otel-proto/examples/CMakeLists.txt
@@ -0,0 +1,7 @@
+set(src test-api.c)
+
+include_directories(${PROJECT_SOURCE_DIR}/include)
+include_directories(${PROJECT_SOURCE_DIR}/proto_c)
+
+add_executable(test-api ${src})
+target_link_libraries(test-api fluent-otel-proto)
diff --git a/fluent-bit/lib/fluent-otel-proto/examples/test-api.c b/fluent-bit/lib/fluent-otel-proto/examples/test-api.c
new file mode 100644
index 00000000..883a16d1
--- /dev/null
+++ b/fluent-bit/lib/fluent-otel-proto/examples/test-api.c
@@ -0,0 +1,29 @@
+/* -*- Mode: C; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+
+/* Fluent Bit
+ * ==========
+ * Copyright (C) 2022 The Fluent Bit Authors
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#include <stdio.h>
+#include <fluent-otel-proto/fluent-otel.h>
+
+int main()
+{
+ int ret;
+
+ fluent_otel_info();
+ return 0;
+}