summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/lib/jansson-e23f558/doc/Makefile.am
parentInitial commit. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/jansson-e23f558/doc/Makefile.am')
-rw-r--r--fluent-bit/lib/jansson-e23f558/doc/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/fluent-bit/lib/jansson-e23f558/doc/Makefile.am b/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
new file mode 100644
index 00000000..8186a7db
--- /dev/null
+++ b/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
@@ -0,0 +1,20 @@
+EXTRA_DIST = conf.py apiref.rst changes.rst conformance.rst \
+ gettingstarted.rst github_commits.c index.rst threadsafety.rst \
+ tutorial.rst upgrading.rst ext/refcounting.py
+
+SPHINXBUILD = sphinx-build
+SPHINXOPTS = -d _build/doctrees $(SPHINXOPTS_EXTRA)
+
+html-local:
+ $(SPHINXBUILD) -b html $(SPHINXOPTS) $(srcdir) _build/html
+
+install-html-local: html
+ mkdir -p $(DESTDIR)$(htmldir)
+ cp -r _build/html $(DESTDIR)$(htmldir)
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(htmldir)
+
+clean-local:
+ rm -rf _build
+ rm -f ext/refcounting.pyc