summaryrefslogtreecommitdiffstats
path: root/logsmanagement/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /logsmanagement/Makefile.am
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'logsmanagement/Makefile.am')
-rw-r--r--logsmanagement/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/logsmanagement/Makefile.am b/logsmanagement/Makefile.am
new file mode 100644
index 00000000..33f08d55
--- /dev/null
+++ b/logsmanagement/Makefile.am
@@ -0,0 +1,28 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+userlogsmanagconfigdir=$(configdir)/logsmanagement.d
+
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(userlogsmanagconfigdir)
+
+dist_libconfig_DATA = \
+ stock_conf/logsmanagement.d.conf \
+ $(NULL)
+
+logsmanagconfigdir=$(libconfigdir)/logsmanagement.d
+
+dist_logsmanagconfig_DATA = \
+ stock_conf/logsmanagement.d/default.conf \
+ stock_conf/logsmanagement.d/example_forward.conf \
+ stock_conf/logsmanagement.d/example_mqtt.conf \
+ stock_conf/logsmanagement.d/example_serial.conf \
+ stock_conf/logsmanagement.d/example_syslog.conf \
+ $(NULL)
+
+dist_noinst_DATA = \
+ README.md \
+ $(NULL)