summaryrefslogtreecommitdiffstats
path: root/mqtt_websockets/c_rhash/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /mqtt_websockets/c_rhash/Makefile.am
parentInitial commit. (diff)
downloadnetdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.tar.xz
netdata-be1c7e50e1e8809ea56f2c9d472eccd8ffd73a97.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'mqtt_websockets/c_rhash/Makefile.am')
-rw-r--r--mqtt_websockets/c_rhash/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/mqtt_websockets/c_rhash/Makefile.am b/mqtt_websockets/c_rhash/Makefile.am
new file mode 100644
index 00000000..2fe5ebee
--- /dev/null
+++ b/mqtt_websockets/c_rhash/Makefile.am
@@ -0,0 +1,21 @@
+crhash_includedir = -I$(abs_top_srcdir)/include
+
+dist_doc_DATA = LICENSE \
+ README.md \
+ $(NULL)
+
+CRHASH_FILES = src/c_rhash.c \
+ src/c_rhash.h \
+ $(NULL)
+
+lib_LIBRARIES = libcrhash.a
+
+libcrhash_a_SOURCES = $(CRHASH_FILES)
+
+libcrhash_a_CFLAGS = $(crhash_includedir)
+
+bin_PROGRAMS = test
+test_LDADD = libcrhash.a
+
+test_SOURCES = src/tests.c
+test_CFLAGS = $(crhash_includedir)