summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
parentInitial commit. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/deps/yaml/CMakeLists.txt')
-rw-r--r--web/server/h2o/libh2o/deps/yaml/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt b/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
new file mode 100644
index 00000000..e84c28cd
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Minimal CMake project for building a static library under Windows.
+
+cmake_minimum_required (VERSION 2.8)
+project (yaml C)
+
+set (YAML_VERSION_MAJOR 0)
+set (YAML_VERSION_MINOR 1)
+set (YAML_VERSION_PATCH 6)
+set (YAML_VERSION_STRING "${YAML_VERSION_MAJOR}.${YAML_VERSION_MINOR}.${YAML_VERSION_PATCH}")
+
+file (GLOB SRC src/*.c)
+
+include_directories (include win32)
+add_definitions (-DHAVE_CONFIG_H -DYAML_DECLARE_STATIC)
+add_library (yaml STATIC ${SRC})
+