summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /web/server/h2o/libh2o/deps/yaml/include/Makefile.am
parentInitial commit. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/deps/yaml/include/Makefile.am')
-rw-r--r--web/server/h2o/libh2o/deps/yaml/include/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/yaml/include/Makefile.am b/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
new file mode 100644
index 00000000..f81863cb
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = yaml.h
+DOXYGEN_CFG = $(top_srcdir)/doc/doxygen.cfg
+
+nobase_include_HEADERS = $(INCLUDES)
+
+if DOXYGEN
+
+html: $(INCLUDES) $(DOXYGEN_CFG)
+ PACKAGE=$(PACKAGE) VERSION=$(VERSION) top_srcdir=$(top_srcdir) top_builddir=$(top_builddir) doxygen $(DOXYGEN_CFG)
+
+endif
+
+maintainer-clean-local:
+ -rm -rf $(top_builddir)/doc/html
+
+dist-hook: html
+ cp -a $(top_builddir)/doc/html $(top_distdir)/doc