summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/misc/libressl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 02:57:58 +0000
commitbe1c7e50e1e8809ea56f2c9d472eccd8ffd73a97 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /web/server/h2o/libh2o/misc/libressl.mk
parentInitial commit. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.44.3.upstream/1.44.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/misc/libressl.mk')
-rw-r--r--web/server/h2o/libh2o/misc/libressl.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/misc/libressl.mk b/web/server/h2o/libh2o/misc/libressl.mk
new file mode 100644
index 00000000..d20df414
--- /dev/null
+++ b/web/server/h2o/libh2o/misc/libressl.mk
@@ -0,0 +1,12 @@
+SOURCE_DIR=.
+VERSION=2.4.5
+ARCHIVE=$(SOURCE_DIR)/libressl-$(VERSION).tar.gz
+DEST=libressl-build
+UNAME=$(shell uname -s)
+
+all: $(DEST)/lib/libssl.a
+
+$(DEST)/lib/libssl.a: $(ARCHIVE)
+ if [ ! -e "libressl-$(VERSION)" ] ; then tar xzf "$(ARCHIVE)" ; fi
+ if [ ! -e "libressl-$(VERSION)/Makefile" ] ; then (P=`pwd`/$(DEST); cd libressl-$(VERSION) && ./configure --prefix="$$P" --libdir="$$P/lib" --disable-shared `test "$(UNAME)" = "Darwin" && echo '--disable-asm'`) ; fi
+ (cd libressl-$(VERSION) && make && make install)