summaryrefslogtreecommitdiffstats
path: root/exporting/opentsdb
diff options
context:
space:
mode:
Diffstat (limited to 'exporting/opentsdb')
-rw-r--r--exporting/opentsdb/Makefile.am8
l---------exporting/opentsdb/README.md1
-rw-r--r--exporting/opentsdb/integrations/opentsdb.md175
-rw-r--r--exporting/opentsdb/metadata.yaml176
-rw-r--r--exporting/opentsdb/opentsdb.c399
-rw-r--r--exporting/opentsdb/opentsdb.h26
6 files changed, 785 insertions, 0 deletions
diff --git a/exporting/opentsdb/Makefile.am b/exporting/opentsdb/Makefile.am
new file mode 100644
index 00000000..161784b8
--- /dev/null
+++ b/exporting/opentsdb/Makefile.am
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+dist_noinst_DATA = \
+ README.md \
+ $(NULL)
diff --git a/exporting/opentsdb/README.md b/exporting/opentsdb/README.md
new file mode 120000
index 00000000..fef53460
--- /dev/null
+++ b/exporting/opentsdb/README.md
@@ -0,0 +1 @@
+integrations/opentsdb.md \ No newline at end of file
diff --git a/exporting/opentsdb/integrations/opentsdb.md b/exporting/opentsdb/integrations/opentsdb.md
new file mode 100644
index 00000000..1c3087e0
--- /dev/null
+++ b/exporting/opentsdb/integrations/opentsdb.md
@@ -0,0 +1,175 @@
+<!--startmeta
+custom_edit_url: "https://github.com/netdata/netdata/edit/master/exporting/opentsdb/README.md"
+meta_yaml: "https://github.com/netdata/netdata/edit/master/exporting/opentsdb/metadata.yaml"
+sidebar_label: "OpenTSDB"
+learn_status: "Published"
+learn_rel_path: "Exporting"
+message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE EXPORTER'S metadata.yaml FILE"
+endmeta-->
+
+# OpenTSDB
+
+
+<img src="https://netdata.cloud/img/opentsdb.png" width="150"/>
+
+
+Use the OpenTSDB connector for the exporting engine to archive your Netdata metrics to OpenTSDB databases for long-term storage,
+further analysis, or correlation with data from other sources.
+
+
+
+<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
+
+## Setup
+
+### Prerequisites
+
+####
+
+- OpenTSDB and Netdata, installed, configured and operational.
+
+
+
+### Configuration
+
+#### File
+
+The configuration file name for this integration is `exporting.conf`.
+
+
+You can edit the configuration file using the `edit-config` script from the
+Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
+
+```bash
+cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
+sudo ./edit-config exporting.conf
+```
+#### Options
+
+The following options can be defined for this exporter.
+
+<details><summary>Config options</summary>
+
+| Name | Description | Default | Required |
+|:----|:-----------|:-------|:--------:|
+| enabled | Enables or disables an exporting connector instance (yes/no). | no | yes |
+| destination | Accepts a space separated list of hostnames, IPs (IPv4 and IPv6) and ports to connect to. Netdata will use the first available to send the metrics. | no | yes |
+| username | Username for HTTP authentication | my_username | no |
+| password | Password for HTTP authentication | my_password | no |
+| data source | Selects the kind of data that will be sent to the external database. (as collected/average/sum) | | no |
+| hostname | The hostname to be used for sending data to the external database server. | [global].hostname | no |
+| prefix | The prefix to add to all metrics. | Netdata | no |
+| update every | Frequency of sending sending data to the external database, in seconds. | 10 | no |
+| buffer on failures | The number of iterations (`update every` seconds) to buffer data, when the external database server is not available. | 10 | no |
+| timeout ms | The timeout in milliseconds to wait for the external database server to process the data. | 2 * update_every * 1000 | no |
+| send hosts matching | Hosts filter. Determines which hosts will be sent to OpenTSDB. The syntax is [simple patterns](https://github.com/netdata/netdata/tree/master/libnetdata/simple_pattern#simple-patterns). | localhost * | no |
+| send charts matching | One or more space separated patterns (use * as wildcard) checked against both chart id and chart name. | * | no |
+| send names instead of ids | Controls the metric names Netdata should send to the external database (yes/no). | | no |
+| send configured labels | Controls if host labels defined in the `[host labels]` section in `netdata.conf` should be sent to the external database (yes/no). | | no |
+| send automatic labels | Controls if automatically created labels, like `_os_name` or `_architecture` should be sent to the external database (yes/no). | | no |
+
+##### destination
+
+The format of each item in this list, is: [PROTOCOL:]IP[:PORT].
+- PROTOCOL can be udp or tcp. tcp is the default and only supported by the current exporting engine.
+- IP can be XX.XX.XX.XX (IPv4), or [XX:XX...XX:XX] (IPv6). For IPv6 you can to enclose the IP in [] to separate it from the port.
+- PORT can be a number of a service name. If omitted, the default port for the exporting connector will be used (opentsdb = 4242).
+
+Example IPv4:
+ ```yaml
+ destination = 10.11.14.2:4242 10.11.14.3:4242 10.11.14.4:4242
+ ```
+Example IPv6 and IPv4 together:
+```yaml
+destination = [ffff:...:0001]:2003 10.11.12.1:2003
+```
+When multiple servers are defined, Netdata will try the next one when the previous one fails.
+
+
+##### update every
+
+Netdata will add some randomness to this number, to prevent stressing the external server when many Netdata servers
+send data to the same database. This randomness does not affect the quality of the data, only the time they are sent.
+
+
+##### buffer on failures
+
+If the server fails to receive the data after that many failures, data loss on the connector instance is expected (Netdata will also log it).
+
+
+##### send hosts matching
+
+Includes one or more space separated patterns, using * as wildcard (any number of times within each pattern).
+The patterns are checked against the hostname (the localhost is always checked as localhost), allowing us to
+filter which hosts will be sent to the external database when this Netdata is a central Netdata aggregating multiple hosts.
+
+A pattern starting with `!` gives a negative match. So to match all hosts named `*db*` except hosts containing `*child*`,
+use `!*child* *db*` (so, the order is important: the first pattern matching the hostname will be used - positive or negative).
+
+
+##### send charts matching
+
+A pattern starting with ! gives a negative match. So to match all charts named apps.* except charts ending in *reads,
+use !*reads apps.* (so, the order is important: the first pattern matching the chart id or the chart name will be used,
+positive or negative). There is also a URL parameter filter that can be used while querying allmetrics. The URL parameter
+has a higher priority than the configuration option.
+
+
+##### send names instead of ids
+
+Netdata supports names and IDs for charts and dimensions. Usually IDs are unique identifiers as read by the system and names
+are human friendly labels (also unique). Most charts and metrics have the same ID and name, but in several cases they are
+different : disks with device-mapper, interrupts, QoS classes, statsd synthetic charts, etc.
+
+
+</details>
+
+#### Examples
+
+##### Minimal configuration
+
+Add `:http` or `:https` modifiers to the connector type if you need to use other than a plaintext protocol.
+For example: `opentsdb:http:my_opentsdb_instance`, `opentsdb:https:my_opentsdb_instance`.
+
+
+```yaml
+[opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+
+```
+##### HTTP authentication
+
+
+
+```yaml
+[opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ username = my_username
+ password = my_password
+
+```
+##### Using `send hosts matching`
+
+
+
+```yaml
+[opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ send hosts matching = localhost *
+
+```
+##### Using `send charts matching`
+
+
+
+```yaml
+[opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ send charts matching = *
+
+```
+
diff --git a/exporting/opentsdb/metadata.yaml b/exporting/opentsdb/metadata.yaml
new file mode 100644
index 00000000..505c8c59
--- /dev/null
+++ b/exporting/opentsdb/metadata.yaml
@@ -0,0 +1,176 @@
+# yamllint disable rule:line-length
+---
+id: 'export-opentsdb'
+meta:
+ name: 'OpenTSDB'
+ link: 'https://github.com/OpenTSDB/opentsdb'
+ categories:
+ - export
+ icon_filename: 'opentsdb.png'
+keywords:
+ - exporter
+ - OpenTSDB
+ - scalable time series
+overview:
+ exporter_description: |
+ Use the OpenTSDB connector for the exporting engine to archive your Netdata metrics to OpenTSDB databases for long-term storage,
+ further analysis, or correlation with data from other sources.
+ exporter_limitations: ''
+setup:
+ prerequisites:
+ list:
+ - title: ''
+ description: |
+ - OpenTSDB and Netdata, installed, configured and operational.
+ configuration:
+ file:
+ name: 'exporting.conf'
+ options:
+ description: 'The following options can be defined for this exporter.'
+ folding:
+ title: 'Config options'
+ enabled: true
+ list:
+ - name: 'enabled'
+ default_value: 'no'
+ description: 'Enables or disables an exporting connector instance (yes|no).'
+ required: true
+ - name: 'destination'
+ default_value: 'no'
+ description: 'Accepts a space separated list of hostnames, IPs (IPv4 and IPv6) and ports to connect to. Netdata will use the first available to send the metrics.'
+ required: true
+ detailed_description: |
+ The format of each item in this list, is: [PROTOCOL:]IP[:PORT].
+ - PROTOCOL can be udp or tcp. tcp is the default and only supported by the current exporting engine.
+ - IP can be XX.XX.XX.XX (IPv4), or [XX:XX...XX:XX] (IPv6). For IPv6 you can to enclose the IP in [] to separate it from the port.
+ - PORT can be a number of a service name. If omitted, the default port for the exporting connector will be used (opentsdb = 4242).
+
+ Example IPv4:
+ ```yaml
+ destination = 10.11.14.2:4242 10.11.14.3:4242 10.11.14.4:4242
+ ```
+ Example IPv6 and IPv4 together:
+ ```yaml
+ destination = [ffff:...:0001]:2003 10.11.12.1:2003
+ ```
+ When multiple servers are defined, Netdata will try the next one when the previous one fails.
+ - name: 'username'
+ default_value: 'my_username'
+ description: 'Username for HTTP authentication'
+ required: false
+ - name: 'password'
+ default_value: 'my_password'
+ description: 'Password for HTTP authentication'
+ required: false
+ - name: 'data source'
+ default_value: ''
+ description: 'Selects the kind of data that will be sent to the external database. (as collected|average|sum)'
+ required: false
+ - name: 'hostname'
+ default_value: '[global].hostname'
+ description: 'The hostname to be used for sending data to the external database server.'
+ required: false
+ - name: 'prefix'
+ default_value: 'Netdata'
+ description: 'The prefix to add to all metrics.'
+ required: false
+ - name: 'update every'
+ default_value: '10'
+ description: |
+ Frequency of sending sending data to the external database, in seconds.
+ required: false
+ detailed_description: |
+ Netdata will add some randomness to this number, to prevent stressing the external server when many Netdata servers
+ send data to the same database. This randomness does not affect the quality of the data, only the time they are sent.
+ - name: 'buffer on failures'
+ default_value: '10'
+ description: |
+ The number of iterations (`update every` seconds) to buffer data, when the external database server is not available.
+ required: false
+ detailed_description: |
+ If the server fails to receive the data after that many failures, data loss on the connector instance is expected (Netdata will also log it).
+ - name: 'timeout ms'
+ default_value: '2 * update_every * 1000'
+ description: 'The timeout in milliseconds to wait for the external database server to process the data.'
+ required: false
+ - name: 'send hosts matching'
+ default_value: 'localhost *'
+ description: |
+ Hosts filter. Determines which hosts will be sent to OpenTSDB. The syntax is [simple patterns](https://github.com/netdata/netdata/tree/master/libnetdata/simple_pattern#simple-patterns).
+ required: false
+ detailed_description: |
+ Includes one or more space separated patterns, using * as wildcard (any number of times within each pattern).
+ The patterns are checked against the hostname (the localhost is always checked as localhost), allowing us to
+ filter which hosts will be sent to the external database when this Netdata is a central Netdata aggregating multiple hosts.
+
+ A pattern starting with `!` gives a negative match. So to match all hosts named `*db*` except hosts containing `*child*`,
+ use `!*child* *db*` (so, the order is important: the first pattern matching the hostname will be used - positive or negative).
+ - name: 'send charts matching'
+ default_value: '*'
+ description: |
+ One or more space separated patterns (use * as wildcard) checked against both chart id and chart name.
+ required: false
+ detailed_description: |
+ A pattern starting with ! gives a negative match. So to match all charts named apps.* except charts ending in *reads,
+ use !*reads apps.* (so, the order is important: the first pattern matching the chart id or the chart name will be used,
+ positive or negative). There is also a URL parameter filter that can be used while querying allmetrics. The URL parameter
+ has a higher priority than the configuration option.
+ - name: 'send names instead of ids'
+ default_value: ''
+ description: 'Controls the metric names Netdata should send to the external database (yes|no).'
+ required: false
+ detailed_description: |
+ Netdata supports names and IDs for charts and dimensions. Usually IDs are unique identifiers as read by the system and names
+ are human friendly labels (also unique). Most charts and metrics have the same ID and name, but in several cases they are
+ different : disks with device-mapper, interrupts, QoS classes, statsd synthetic charts, etc.
+ - name: 'send configured labels'
+ default_value: ''
+ description: 'Controls if host labels defined in the `[host labels]` section in `netdata.conf` should be sent to the external database (yes|no).'
+ required: false
+ - name: 'send automatic labels'
+ default_value: ''
+ description: 'Controls if automatically created labels, like `_os_name` or `_architecture` should be sent to the external database (yes|no).'
+ required: false
+ examples:
+ folding:
+ enabled: true
+ title: ''
+ list:
+ - name: 'Minimal configuration'
+ folding:
+ enabled: false
+ description: |
+ Add `:http` or `:https` modifiers to the connector type if you need to use other than a plaintext protocol.
+ For example: `opentsdb:http:my_opentsdb_instance`, `opentsdb:https:my_opentsdb_instance`.
+ config: |
+ [opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ - name: 'HTTP authentication'
+ folding:
+ enabled: false
+ description: ''
+ config: |
+ [opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ username = my_username
+ password = my_password
+ - name: 'Using `send hosts matching`'
+ folding:
+ enabled: false
+ description: ''
+ config: |
+ [opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ send hosts matching = localhost *
+ - name: 'Using `send charts matching`'
+ folding:
+ enabled: false
+ description: ''
+ config: |
+ [opentsdb:my_opentsdb_instance]
+ enabled = yes
+ destination = localhost:4242
+ send charts matching = *
diff --git a/exporting/opentsdb/opentsdb.c b/exporting/opentsdb/opentsdb.c
new file mode 100644
index 00000000..ffccb5b2
--- /dev/null
+++ b/exporting/opentsdb/opentsdb.c
@@ -0,0 +1,399 @@
+// SPDX-License-Identifier: GPL-3.0-or-later
+
+#include "opentsdb.h"
+#include "../json/json.h"
+
+/**
+ * Initialize OpenTSDB telnet connector instance
+ *
+ * @param instance an instance data structure.
+ * @return Returns 0 on success, 1 on failure.
+ */
+int init_opentsdb_telnet_instance(struct instance *instance)
+{
+ instance->worker = simple_connector_worker;
+
+ struct simple_connector_config *connector_specific_config = callocz(1, sizeof(struct simple_connector_config));
+ instance->config.connector_specific_config = (void *)connector_specific_config;
+ connector_specific_config->default_port = 4242;
+
+ struct simple_connector_data *connector_specific_data = callocz(1, sizeof(struct simple_connector_data));
+ instance->connector_specific_data = connector_specific_data;
+
+#ifdef ENABLE_HTTPS
+ connector_specific_data->ssl = NETDATA_SSL_UNSET_CONNECTION;
+ if (instance->config.options & EXPORTING_OPTION_USE_TLS) {
+ netdata_ssl_initialize_ctx(NETDATA_SSL_EXPORTING_CTX);
+ }
+#endif
+
+ instance->start_batch_formatting = NULL;
+ instance->start_host_formatting = format_host_labels_opentsdb_telnet;
+ instance->start_chart_formatting = NULL;
+
+ if (EXPORTING_OPTIONS_DATA_SOURCE(instance->config.options) == EXPORTING_SOURCE_DATA_AS_COLLECTED)
+ instance->metric_formatting = format_dimension_collected_opentsdb_telnet;
+ else
+ instance->metric_formatting = format_dimension_stored_opentsdb_telnet;
+
+ instance->end_chart_formatting = NULL;
+ instance->variables_formatting = NULL;
+ instance->end_host_formatting = flush_host_labels;
+ instance->end_batch_formatting = simple_connector_end_batch;
+
+ instance->prepare_header = NULL;
+ instance->check_response = exporting_discard_response;
+
+ instance->buffer = (void *)buffer_create(0, &netdata_buffers_statistics.buffers_exporters);
+ if (!instance->buffer) {
+ netdata_log_error("EXPORTING: cannot create buffer for opentsdb telnet exporting connector instance %s", instance->config.name);
+ return 1;
+ }
+
+ simple_connector_init(instance);
+
+ if (uv_mutex_init(&instance->mutex))
+ return 1;
+ if (uv_cond_init(&instance->cond_var))
+ return 1;
+
+ return 0;
+}
+
+/**
+ * Initialize OpenTSDB HTTP connector instance
+ *
+ * @param instance an instance data structure.
+ * @return Returns 0 on success, 1 on failure.
+ */
+int init_opentsdb_http_instance(struct instance *instance)
+{
+ instance->worker = simple_connector_worker;
+
+ struct simple_connector_config *connector_specific_config = callocz(1, sizeof(struct simple_connector_config));
+ instance->config.connector_specific_config = (void *)connector_specific_config;
+ connector_specific_config->default_port = 4242;
+
+ struct simple_connector_data *connector_specific_data = callocz(1, sizeof(struct simple_connector_data));
+#ifdef ENABLE_HTTPS
+ connector_specific_data->ssl = NETDATA_SSL_UNSET_CONNECTION;
+ if (instance->config.options & EXPORTING_OPTION_USE_TLS) {
+ netdata_ssl_initialize_ctx(NETDATA_SSL_EXPORTING_CTX);
+ }
+#endif
+ instance->connector_specific_data = connector_specific_data;
+
+ instance->start_batch_formatting = open_batch_json_http;
+ instance->start_host_formatting = format_host_labels_opentsdb_http;
+ instance->start_chart_formatting = NULL;
+
+ if (EXPORTING_OPTIONS_DATA_SOURCE(instance->config.options) == EXPORTING_SOURCE_DATA_AS_COLLECTED)
+ instance->metric_formatting = format_dimension_collected_opentsdb_http;
+ else
+ instance->metric_formatting = format_dimension_stored_opentsdb_http;
+
+ instance->end_chart_formatting = NULL;
+ instance->variables_formatting = NULL;
+ instance->end_host_formatting = flush_host_labels;
+ instance->end_batch_formatting = close_batch_json_http;
+
+ instance->prepare_header = opentsdb_http_prepare_header;
+ instance->check_response = exporting_discard_response;
+
+ instance->buffer = (void *)buffer_create(0, &netdata_buffers_statistics.buffers_exporters);
+ if (!instance->buffer) {
+ netdata_log_error("EXPORTING: cannot create buffer for opentsdb HTTP exporting connector instance %s", instance->config.name);
+ return 1;
+ }
+
+ simple_connector_init(instance);
+
+ if (uv_mutex_init(&instance->mutex))
+ return 1;
+ if (uv_cond_init(&instance->cond_var))
+ return 1;
+
+ return 0;
+}
+
+/**
+ * Copy a label value and substitute underscores in place of characters which can't be used in OpenTSDB output
+ *
+ * @param dst a destination string.
+ * @param src a source string.
+ * @param len the maximum number of characters copied.
+ */
+
+void sanitize_opentsdb_label_value(char *dst, const char *src, size_t len)
+{
+ while (*src != '\0' && len) {
+ if (isalpha(*src) || isdigit(*src) || *src == '-' || *src == '.' || *src == '/' || IS_UTF8_BYTE(*src))
+ *dst++ = *src;
+ else
+ *dst++ = '_';
+
+ src++;
+ len--;
+ }
+ *dst = '\0';
+}
+
+/**
+ * Format host labels for JSON connector
+ *
+ * @param instance an instance data structure.
+ * @param host a data collecting host.
+ * @return Always returns 0.
+ */
+
+int format_host_labels_opentsdb_telnet(struct instance *instance, RRDHOST *host) {
+ if(!instance->labels_buffer)
+ instance->labels_buffer = buffer_create(1024, &netdata_buffers_statistics.buffers_exporters);
+
+ if (unlikely(!sending_labels_configured(instance)))
+ return 0;
+
+ buffer_strcat(instance->labels_buffer, " ");
+ rrdlabels_to_buffer(host->rrdlabels, instance->labels_buffer, "", "=", "", " ",
+ exporting_labels_filter_callback, instance,
+ NULL, sanitize_opentsdb_label_value);
+ return 0;
+}
+
+/**
+ * Format dimension using collected data for OpenTSDB telnet connector
+ *
+ * @param instance an instance data structure.
+ * @param rd a dimension.
+ * @return Always returns 0.
+ */
+int format_dimension_collected_opentsdb_telnet(struct instance *instance, RRDDIM *rd)
+{
+ RRDSET *st = rd->rrdset;
+ RRDHOST *host = st->rrdhost;
+
+ char chart_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ chart_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && st->name) ? rrdset_name(st) : rrdset_id(st),
+ RRD_ID_LENGTH_MAX);
+
+ char dimension_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ dimension_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && rd->name) ? rrddim_name(rd) : rrddim_id(rd),
+ RRD_ID_LENGTH_MAX);
+
+ buffer_sprintf(
+ instance->buffer,
+ "put %s.%s.%s %llu " COLLECTED_NUMBER_FORMAT " host=%s%s%s%s\n",
+ instance->config.prefix,
+ chart_name,
+ dimension_name,
+ (unsigned long long)rd->collector.last_collected_time.tv_sec,
+ rd->collector.last_collected_value,
+ (host == localhost) ? instance->config.hostname : rrdhost_hostname(host),
+ (host->tags) ? " " : "",
+ (host->tags) ? rrdhost_tags(host) : "",
+ (instance->labels_buffer) ? buffer_tostring(instance->labels_buffer) : "");
+
+ return 0;
+}
+
+/**
+ * Format dimension using a calculated value from stored data for OpenTSDB telnet connector
+ *
+ * @param instance an instance data structure.
+ * @param rd a dimension.
+ * @return Always returns 0.
+ */
+int format_dimension_stored_opentsdb_telnet(struct instance *instance, RRDDIM *rd)
+{
+ RRDSET *st = rd->rrdset;
+ RRDHOST *host = st->rrdhost;
+
+ char chart_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ chart_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && st->name) ? rrdset_name(st) : rrdset_id(st),
+ RRD_ID_LENGTH_MAX);
+
+ char dimension_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ dimension_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && rd->name) ? rrddim_name(rd) : rrddim_id(rd),
+ RRD_ID_LENGTH_MAX);
+
+ time_t last_t;
+ NETDATA_DOUBLE value = exporting_calculate_value_from_stored_data(instance, rd, &last_t);
+
+ if(isnan(value))
+ return 0;
+
+ buffer_sprintf(
+ instance->buffer,
+ "put %s.%s.%s %llu " NETDATA_DOUBLE_FORMAT " host=%s%s%s%s\n",
+ instance->config.prefix,
+ chart_name,
+ dimension_name,
+ (unsigned long long)last_t,
+ value,
+ (host == localhost) ? instance->config.hostname : rrdhost_hostname(host),
+ (host->tags) ? " " : "",
+ (host->tags) ? rrdhost_tags(host) : "",
+ (instance->labels_buffer) ? buffer_tostring(instance->labels_buffer) : "");
+
+ return 0;
+}
+
+/**
+ * Prepare HTTP header
+ *
+ * @param instance an instance data structure.
+ * @return Returns 0 on success, 1 on failure.
+ */
+void opentsdb_http_prepare_header(struct instance *instance)
+{
+ struct simple_connector_data *simple_connector_data = instance->connector_specific_data;
+
+ buffer_sprintf(
+ simple_connector_data->last_buffer->header,
+ "POST /api/put HTTP/1.1\r\n"
+ "Host: %s\r\n"
+ "%s"
+ "Content-Type: application/json\r\n"
+ "Content-Length: %lu\r\n"
+ "\r\n",
+ instance->config.destination,
+ simple_connector_data->auth_string ? simple_connector_data->auth_string : "",
+ (unsigned long int) buffer_strlen(simple_connector_data->last_buffer->buffer));
+
+ return;
+}
+
+/**
+ * Format host labels for OpenTSDB HTTP connector
+ *
+ * @param instance an instance data structure.
+ * @param host a data collecting host.
+ * @return Always returns 0.
+ */
+
+int format_host_labels_opentsdb_http(struct instance *instance, RRDHOST *host) {
+ if (!instance->labels_buffer)
+ instance->labels_buffer = buffer_create(1024, &netdata_buffers_statistics.buffers_exporters);
+
+ if (unlikely(!sending_labels_configured(instance)))
+ return 0;
+
+ rrdlabels_to_buffer(host->rrdlabels, instance->labels_buffer, ",", ":", "\"", "",
+ exporting_labels_filter_callback, instance,
+ NULL, sanitize_opentsdb_label_value);
+ return 0;
+}
+
+/**
+ * Format dimension using collected data for OpenTSDB HTTP connector
+ *
+ * @param instance an instance data structure.
+ * @param rd a dimension.
+ * @return Always returns 0.
+ */
+int format_dimension_collected_opentsdb_http(struct instance *instance, RRDDIM *rd)
+{
+ RRDSET *st = rd->rrdset;
+ RRDHOST *host = st->rrdhost;
+
+ char chart_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ chart_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && st->name) ? rrdset_name(st) : rrdset_id(st),
+ RRD_ID_LENGTH_MAX);
+
+ char dimension_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ dimension_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && rd->name) ? rrddim_name(rd) : rrddim_id(rd),
+ RRD_ID_LENGTH_MAX);
+
+ if (buffer_strlen((BUFFER *)instance->buffer) > 2)
+ buffer_strcat(instance->buffer, ",\n");
+
+ buffer_sprintf(
+ instance->buffer,
+ "{"
+ "\"metric\":\"%s.%s.%s\","
+ "\"timestamp\":%llu,"
+ "\"value\":"COLLECTED_NUMBER_FORMAT","
+ "\"tags\":{"
+ "\"host\":\"%s%s%s\"%s"
+ "}"
+ "}",
+ instance->config.prefix,
+ chart_name,
+ dimension_name,
+ (unsigned long long)rd->collector.last_collected_time.tv_sec,
+ rd->collector.last_collected_value,
+ (host == localhost) ? instance->config.hostname : rrdhost_hostname(host),
+ (host->tags) ? " " : "",
+ (host->tags) ? rrdhost_tags(host) : "",
+ instance->labels_buffer ? buffer_tostring(instance->labels_buffer) : "");
+
+ return 0;
+}
+
+/**
+ * Format dimension using a calculated value from stored data for OpenTSDB HTTP connector
+ *
+ * @param instance an instance data structure.
+ * @param rd a dimension.
+ * @return Always returns 0.
+ */
+int format_dimension_stored_opentsdb_http(struct instance *instance, RRDDIM *rd)
+{
+ RRDSET *st = rd->rrdset;
+ RRDHOST *host = st->rrdhost;
+
+ char chart_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ chart_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && st->name) ? rrdset_name(st) : rrdset_id(st),
+ RRD_ID_LENGTH_MAX);
+
+ char dimension_name[RRD_ID_LENGTH_MAX + 1];
+ exporting_name_copy(
+ dimension_name,
+ (instance->config.options & EXPORTING_OPTION_SEND_NAMES && rd->name) ? rrddim_name(rd) : rrddim_id(rd),
+ RRD_ID_LENGTH_MAX);
+
+ time_t last_t;
+ NETDATA_DOUBLE value = exporting_calculate_value_from_stored_data(instance, rd, &last_t);
+
+ if(isnan(value))
+ return 0;
+
+ if (buffer_strlen((BUFFER *)instance->buffer) > 2)
+ buffer_strcat(instance->buffer, ",\n");
+
+ buffer_sprintf(
+ instance->buffer,
+ "{"
+ "\"metric\":\"%s.%s.%s\","
+ "\"timestamp\":%llu,"
+ "\"value\":" NETDATA_DOUBLE_FORMAT ","
+ "\"tags\":{"
+ "\"host\":\"%s%s%s\"%s"
+ "}"
+ "}",
+ instance->config.prefix,
+ chart_name,
+ dimension_name,
+ (unsigned long long)last_t,
+ value,
+ (host == localhost) ? instance->config.hostname : rrdhost_hostname(host),
+ (host->tags) ? " " : "",
+ (host->tags) ? rrdhost_tags(host) : "",
+ instance->labels_buffer ? buffer_tostring(instance->labels_buffer) : "");
+
+ return 0;
+}
diff --git a/exporting/opentsdb/opentsdb.h b/exporting/opentsdb/opentsdb.h
new file mode 100644
index 00000000..b544ba8c
--- /dev/null
+++ b/exporting/opentsdb/opentsdb.h
@@ -0,0 +1,26 @@
+// SPDX-License-Identifier: GPL-3.0-or-later
+
+#ifndef NETDATA_EXPORTING_OPENTSDB_H
+#define NETDATA_EXPORTING_OPENTSDB_H
+
+#include "exporting/exporting_engine.h"
+
+int init_opentsdb_telnet_instance(struct instance *instance);
+int init_opentsdb_http_instance(struct instance *instance);
+
+void sanitize_opentsdb_label_value(char *dst, const char *src, size_t len);
+int format_host_labels_opentsdb_telnet(struct instance *instance, RRDHOST *host);
+int format_host_labels_opentsdb_http(struct instance *instance, RRDHOST *host);
+
+int format_dimension_collected_opentsdb_telnet(struct instance *instance, RRDDIM *rd);
+int format_dimension_stored_opentsdb_telnet(struct instance *instance, RRDDIM *rd);
+
+int format_dimension_collected_opentsdb_http(struct instance *instance, RRDDIM *rd);
+int format_dimension_stored_opentsdb_http(struct instance *instance, RRDDIM *rd);
+
+int open_batch_opentsdb_http(struct instance *instance);
+int close_batch_opentsdb_http(struct instance *instance);
+
+void opentsdb_http_prepare_header(struct instance *instance);
+
+#endif //NETDATA_EXPORTING_OPENTSDB_H