summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt')
-rw-r--r--fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt b/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
new file mode 100644
index 00000000..3321956d
--- /dev/null
+++ b/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Write ares_build.h configuration file. This is an installed file.
+CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h)
+
+# Headers installation target
+IF (CARES_INSTALL)
+ SET (CARES_HEADERS ares.h ares_version.h "${PROJECT_BINARY_DIR}/ares_build.h" ares_rules.h ares_dns.h ares_nameser.h)
+ INSTALL (FILES ${CARES_HEADERS} COMPONENT Devel DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ENDIF ()