summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile')
-rw-r--r--web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
new file mode 100644
index 00000000..0edaa7cb
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
@@ -0,0 +1,12 @@
+# Tested on FreeBSD, Ubuntu 10.04 and Cygwin
+CC=gcc
+CFLAGS=-c -Wall -std=c99 -pedantic
+LDFLAGS=-lcrypto -lssl
+
+all: test_client
+
+test_client: test_client.o openssl_hostname_validation.o
+ $(CC) test_client.o openssl_hostname_validation.o -o test_client $(LDFLAGS)
+
+clean:
+ rm -rf *.o test_client