summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw
diff options
context:
space:
mode:
Diffstat (limited to 'web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw')
-rw-r--r--web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw18
1 files changed, 18 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw
new file mode 100644
index 00000000..00f63144
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw
@@ -0,0 +1,18 @@
+# Tested on Windows 7 with MinGW-w64
+CC=gcc
+CFLAGS=-c -Wall
+LDFLAGS= -leay32 -lssl32
+
+all: test_client
+
+test_client: test_client.o openssl_hostname_validation.o
+ $(CC) test_client.o openssl_hostname_validation.o -o test_client $(LDFLAGS)
+
+test_client.o: test_client.c
+ $(CC) $(CFLAGS) test_client.c
+
+openssl_hostname_validation.o: openssl_hostname_validation.c
+ $(CC) $(CFLAGS) openssl_hostname_validation.c
+
+clean:
+ rm -rf *.o test_client.exe