summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:52:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:52:22 +0000
commit6a7eecec57783a042d12f895d5ae148c44f4d074 (patch)
tree77a2c3c5612655f1dd15e9a2ddf14e13bab90b1f /configure.ac
parentReleasing progress-linux version 1.59.0-1~progress7.99u1. (diff)
downloadnghttp2-6a7eecec57783a042d12f895d5ae148c44f4d074.tar.xz
nghttp2-6a7eecec57783a042d12f895d5ae148c44f4d074.zip
Merging upstream version 1.60.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac102
1 files changed, 56 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index defc113..0fb1ae4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,7 +25,7 @@ dnl Do not change user variables!
dnl https://www.gnu.org/software/automake/manual/html_node/Flag-Variables-Ordering.html
AC_PREREQ(2.61)
-AC_INIT([nghttp2], [1.59.0], [t-tujikawa@users.sourceforge.net])
+AC_INIT([nghttp2], [1.60.0], [t-tujikawa@users.sourceforge.net])
AC_CONFIG_AUX_DIR([.])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
@@ -44,9 +44,9 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
dnl See versioning rule:
dnl https://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-AC_SUBST(LT_CURRENT, 40)
+AC_SUBST(LT_CURRENT, 41)
AC_SUBST(LT_REVISION, 0)
-AC_SUBST(LT_AGE, 26)
+AC_SUBST(LT_AGE, 27)
major=`echo $PACKAGE_VERSION |cut -d. -f1 | sed -e "s/[^0-9]//g"`
minor=`echo $PACKAGE_VERSION |cut -d. -f2 | sed -e "s/[^0-9]//g"`
@@ -137,11 +137,6 @@ AC_ARG_WITH([libev],
[Use libev [default=check]])],
[request_libev=$withval], [request_libev=check])
-AC_ARG_WITH([cunit],
- [AS_HELP_STRING([--with-cunit],
- [Use cunit [default=check]])],
- [request_cunit=$withval], [request_cunit=check])
-
AC_ARG_WITH([jemalloc],
[AS_HELP_STRING([--with-jemalloc],
[Use jemalloc [default=check]])],
@@ -177,6 +172,16 @@ AC_ARG_WITH([libbpf],
[Use libbpf [default=no]])],
[request_libbpf=$withval], [request_libbpf=no])
+AC_ARG_WITH([libbrotlienc],
+ [AS_HELP_STRING([--with-libbrotlienc],
+ [Use libbrotlienc [default=no]])],
+ [request_libbrotlienc=$withval], [request_libbrotlienc=no])
+
+AC_ARG_WITH([libbrotlidec],
+ [AS_HELP_STRING([--with-libbrotlidec],
+ [Use libbrotlidec [default=no]])],
+ [request_libbrotlidec=$withval], [request_libbrotlidec=no])
+
dnl Define variables
AC_ARG_VAR([LIBEV_CFLAGS], [C compiler flags for libev, skipping any checks])
AC_ARG_VAR([LIBEV_LIBS], [linker flags for libev, skipping any checks])
@@ -377,43 +382,6 @@ case "${host_os}" in
;;
esac
-# cunit
-have_cunit=no
-if test "x${request_cunit}" != "xno"; then
- PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
- # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
- # do this because Debian (Ubuntu) lacks pkg-config file for cunit.
- if test "x${have_cunit}" = "xno"; then
- AC_MSG_WARN([${CUNIT_PKG_ERRORS}])
- AC_CHECK_LIB([cunit], [CU_initialize_registry],
- [have_cunit=yes], [have_cunit=no])
- if test "x${have_cunit}" = "xyes"; then
- CUNIT_LIBS="-lcunit"
- CUNIT_CFLAGS=""
- AC_SUBST([CUNIT_LIBS])
- AC_SUBST([CUNIT_CFLAGS])
- fi
- fi
- if test "x${have_cunit}" = "xyes"; then
- # cunit in Mac OS X requires ncurses. Note that in Mac OS X, test
- # program can be built without -lncurses, but it emits runtime
- # error.
- case "${build}" in
- *-apple-darwin*)
- CUNIT_LIBS="$CUNIT_LIBS -lncurses"
- AC_SUBST([CUNIT_LIBS])
- ;;
- esac
- fi
-fi
-
-if test "x${request_cunit}" = "xyes" &&
- test "x${have_cunit}" != "xyes"; then
- AC_MSG_ERROR([cunit was requested (--with-cunit) but not found])
-fi
-
-AM_CONDITIONAL([HAVE_CUNIT], [ test "x${have_cunit}" = "xyes" ])
-
# libev (for src)
have_libev=no
if test "x${request_libev}" != "xno"; then
@@ -626,6 +594,47 @@ fi
AM_CONDITIONAL([HAVE_LIBBPF], [ test "x${have_libbpf}" = "xyes" ])
+# libbrotlienc (for src)
+have_libbrotlienc=no
+if test "x${request_libbrotlienc}" != "xno"; then
+ PKG_CHECK_MODULES([LIBBROTLIENC], [libbrotlienc >= 1.0.9],
+ [have_libbrotlienc=yes],
+ [have_libbrotlienc=no])
+ if test "x${have_libbrotlienc}" = "xno"; then
+ AC_MSG_NOTICE($LIBBROTLIENC_PKG_ERRORS)
+ fi
+fi
+
+if test "x${request_libbrotlienc}" = "xyes" &&
+ test "x${have_libbrotlienc}" != "xyes"; then
+ AC_MSG_ERROR([libbrotlienc was requested (--with-libbrotlienc) but not found])
+fi
+
+# libbrotlidec (for src)
+have_libbrotlidec=no
+if test "x${request_libbrotlidec}" != "xno"; then
+ PKG_CHECK_MODULES([LIBBROTLIDEC], [libbrotlidec >= 1.0.9],
+ [have_libbrotlidec=yes],
+ [have_libbrotlidec=no])
+ if test "x${have_libbrotlidec}" = "xno"; then
+ AC_MSG_NOTICE($LIBBROTLIDEC_PKG_ERRORS)
+ fi
+fi
+
+if test "x${request_libbrotlidec}" = "xyes" &&
+ test "x${have_libbrotlidec}" != "xyes"; then
+ AC_MSG_ERROR([libbrotlidec was requested (--with-libbrotlidec) but not found])
+fi
+
+have_libbrotli=no
+if test "x${have_libbrotlienc}" = "xyes" &&
+ test "x${have_libbrotlidec}" = "xyes"; then
+ have_libbrotli=yes
+
+ AC_DEFINE([HAVE_LIBBROTLI], [1],
+ [Define to 1 if you have `libbrotlienc` and `libbrotlidec` libraries.])
+fi
+
# libevent_openssl (for examples)
# 2.0.8 is required because we use evconnlistener_set_error_cb()
have_libevent_openssl=no
@@ -1155,7 +1164,6 @@ AC_MSG_NOTICE([summary of build options:
Python: ${PYTHON}
PYTHON_VERSION: ${PYTHON_VERSION}
Test:
- CUnit: ${have_cunit} (CFLAGS='${CUNIT_CFLAGS}' LIBS='${CUNIT_LIBS}')
Failmalloc: ${enable_failmalloc}
Libs:
OpenSSL: ${have_openssl} (CFLAGS='${OPENSSL_CFLAGS}' LIBS='${OPENSSL_LIBS}')
@@ -1172,6 +1180,8 @@ AC_MSG_NOTICE([summary of build options:
Jemalloc: ${have_jemalloc} (CFLAGS='${JEMALLOC_CFLAGS}' LIBS='${JEMALLOC_LIBS}')
Zlib: ${have_zlib} (CFLAGS='${ZLIB_CFLAGS}' LIBS='${ZLIB_LIBS}')
Systemd: ${have_libsystemd} (CFLAGS='${SYSTEMD_CFLAGS}' LIBS='${SYSTEMD_LIBS}')
+ Libbrotlienc: ${have_libbrotlienc} (CFLAGS="${LIBBROTLIENC_CFLAGS}' LIBS='${LIBBROTLIENC_LIBS}')
+ Libbrotlidec: ${have_libbrotlidec} (CFLAGS="${LIBBROTLIDEC_CFLAGS}' LIBS='${LIBBROTLIDEC_LIBS}')
Third-party:
http-parser: ${enable_third_party}
MRuby: ${have_mruby} (CFLAGS='${LIBMRUBY_CFLAGS}' LIBS='${LIBMRUBY_LIBS}')