summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:52:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:52:22 +0000
commit6a7eecec57783a042d12f895d5ae148c44f4d074 (patch)
tree77a2c3c5612655f1dd15e9a2ddf14e13bab90b1f /tests/Makefile.am
parentReleasing progress-linux version 1.59.0-1~progress7.99u1. (diff)
downloadnghttp2-6a7eecec57783a042d12f895d5ae148c44f4d074.tar.xz
nghttp2-6a7eecec57783a042d12f895d5ae148c44f4d074.zip
Merging upstream version 1.60.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1c506d8..456f65f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,9 +22,7 @@
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
SUBDIRS = testdata
-EXTRA_DIST = CMakeLists.txt
-
-if HAVE_CUNIT
+EXTRA_DIST = CMakeLists.txt munit/COPYING
check_PROGRAMS = main
@@ -43,17 +41,20 @@ OBJECTS = main.c nghttp2_pq_test.c nghttp2_map_test.c nghttp2_queue_test.c \
nghttp2_buf_test.c \
nghttp2_http_test.c \
nghttp2_extpri_test.c \
- nghttp2_ratelim_test.c
+ nghttp2_ratelim_test.c \
+ munit/munit.c
HFILES = nghttp2_pq_test.h nghttp2_map_test.h nghttp2_queue_test.h \
nghttp2_session_test.h \
nghttp2_frame_test.h nghttp2_stream_test.h nghttp2_hd_test.h \
nghttp2_alpn_test.h nghttp2_helper_test.h \
+ nghttp2_assertion.h \
nghttp2_test_helper.h \
nghttp2_buf_test.h \
nghttp2_http_test.h \
nghttp2_extpri_test.h \
- nghttp2_ratelim_test.h
+ nghttp2_ratelim_test.h \
+ munit/munit.h
main_SOURCES = $(HFILES) $(OBJECTS)
@@ -65,13 +66,14 @@ else
main_LDADD = ${top_builddir}/lib/.libs/*.o
endif
-main_LDADD += @CUNIT_LIBS@ @TESTLDADD@
+main_LDADD += @TESTLDADD@
main_LDFLAGS = -static
if ENABLE_FAILMALLOC
failmalloc_SOURCES = failmalloc.c failmalloc_test.c failmalloc_test.h \
malloc_wrapper.c malloc_wrapper.h \
- nghttp2_test_helper.c nghttp2_test_helper.h
+ nghttp2_test_helper.c nghttp2_test_helper.h \
+ munit/munit.c munit/munit.h
failmalloc_LDADD = $(main_LDADD)
failmalloc_LDFLAGS = $(main_LDFLAGS)
endif # ENABLE_FAILMALLOC
@@ -79,15 +81,14 @@ endif # ENABLE_FAILMALLOC
AM_CFLAGS = $(WARNCFLAGS) \
-I${top_srcdir}/lib \
-I${top_srcdir}/lib/includes \
+ -I${top_srcdir}/tests/munit \
-I${top_builddir}/lib/includes \
-DBUILDING_NGHTTP2 \
-DNGHTTP2_STATICLIB \
- @CUNIT_CFLAGS@ @DEFS@
+ @DEFS@
TESTS = main
if ENABLE_FAILMALLOC
TESTS += failmalloc
endif # ENABLE_FAILMALLOC
-
-endif # HAVE_CUNIT