summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:42:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:42:38 +0000
commit147b254d4d222ee9aa02246904fac06a79097c90 (patch)
tree105bae5fbb8ce1799b4772f8ad3053bcacd97153 /debian/patches
parentReleasing progress-linux version 7.94+git20230807.3be01efb1+dfsg-2~progress7.... (diff)
downloadnmap-147b254d4d222ee9aa02246904fac06a79097c90.tar.xz
nmap-147b254d4d222ee9aa02246904fac06a79097c90.zip
Merging debian version 7.94+git20230807.3be01efb1+dfsg-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-use-su-to-root.patch23
-rw-r--r--debian/patches/0003-Make-uninstaller-not-fail-on-unparseable-versions.patch16
-rw-r--r--debian/patches/0004-Ignore-errors-of-install-d-invocations.patch64
-rw-r--r--debian/patches/series3
4 files changed, 106 insertions, 0 deletions
diff --git a/debian/patches/0001-use-su-to-root.patch b/debian/patches/0001-use-su-to-root.patch
new file mode 100644
index 0000000..1f06979
--- /dev/null
+++ b/debian/patches/0001-use-su-to-root.patch
@@ -0,0 +1,23 @@
+From: Hilko Bengen <bengen@debian.org>
+Date: Fri, 25 Apr 2014 09:51:17 +0200
+Subject: use su-to-root
+
+---
+ zenmap/install_scripts/unix/zenmap-root.desktop | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/zenmap/install_scripts/unix/zenmap-root.desktop b/zenmap/install_scripts/unix/zenmap-root.desktop
+index c5f4c10..f50029d 100644
+--- a/zenmap/install_scripts/unix/zenmap-root.desktop
++++ b/zenmap/install_scripts/unix/zenmap-root.desktop
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+ Name=Zenmap (as root)
+ GenericName=GUI Port Scanner
+-TryExec=su-to-zenmap.sh
+-Exec=su-to-zenmap.sh %F
++TryExec=pkexec
++Exec=pkexec /usr/bin/zenmap %F
+ Terminal=false
+ Icon=zenmap
+ Type=Application
diff --git a/debian/patches/0003-Make-uninstaller-not-fail-on-unparseable-versions.patch b/debian/patches/0003-Make-uninstaller-not-fail-on-unparseable-versions.patch
new file mode 100644
index 0000000..6bb0016
--- /dev/null
+++ b/debian/patches/0003-Make-uninstaller-not-fail-on-unparseable-versions.patch
@@ -0,0 +1,16 @@
+From: Hilko Bengen <bengen@debian.org>
+Date: Sun, 24 Dec 2023 20:04:19 +0100
+Subject: Make uninstaller not fail on unparseable versions
+
+... such as 7.94SVN
+---
+ zenmap/zenmapCore/Version.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/zenmap/zenmapCore/Version.py b/zenmap/zenmapCore/Version.py
+index b3fede4..89ccbfe 100644
+--- a/zenmap/zenmapCore/Version.py
++++ b/zenmap/zenmapCore/Version.py
+@@ -1 +1 @@
+-VERSION = "7.94SVN"
++VERSION = "7.94+SVN"
diff --git a/debian/patches/0004-Ignore-errors-of-install-d-invocations.patch b/debian/patches/0004-Ignore-errors-of-install-d-invocations.patch
new file mode 100644
index 0000000..f4e0e62
--- /dev/null
+++ b/debian/patches/0004-Ignore-errors-of-install-d-invocations.patch
@@ -0,0 +1,64 @@
+From: Hilko Bengen <bengen@debian.org>
+Date: Sun, 24 Dec 2023 20:35:03 +0100
+Subject: Ignore errors of "install -d" invocations
+
+---
+ Makefile.in | 10 +++++-----
+ nping/Makefile.in | 2 +-
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a924301..020be52 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -314,7 +314,7 @@ distclean-%: clean-%
+ -cd $* && $(MAKE) distclean
+
+ install-nmap: $(TARGET)
+- $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
++ -$(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
+ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
+ # Use strip -x to avoid stripping dynamically loaded NSE functions. See
+ # http://seclists.org/nmap-dev/2007/q4/0272.html.
+@@ -368,7 +368,7 @@ build-zenmap: $(ZENMAPDIR)/setup.py $(ZENMAPDIR)/zenmapCore/Version.py
+ cd $(ZENMAPDIR) && $(PYTHON) setup.py build $(if $(DESTDIR),--executable "$(DEFAULT_PYTHON_PATH)")
+
+ install-zenmap: $(ZENMAPDIR)/setup.py
+- $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
++ -$(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
+ cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)")
+ $(INSTALL) -c -m 644 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/
+ # Create a symlink from nmapfe to zenmap if nmapfe doesn't exist or is
+@@ -392,8 +392,8 @@ NSE_FILES = scripts/script.db scripts/*.nse
+ NSE_LIB_LUA_FILES = nselib/*.lua nselib/*.luadoc
+
+ install-nse: $(TARGET)
+- $(INSTALL) -d $(DESTDIR)$(nmapdatadir)/scripts
+- $(INSTALL) -d $(DESTDIR)$(nmapdatadir)/nselib
++ -$(INSTALL) -d $(DESTDIR)$(nmapdatadir)/scripts
++ -$(INSTALL) -d $(DESTDIR)$(nmapdatadir)/nselib
+
+ # Remove obsolete scripts from a previous installation.
+ (cd $(DESTDIR)$(nmapdatadir)/scripts && rm -f $(OLD_SCRIPT_NAMES))
+@@ -401,7 +401,7 @@ install-nse: $(TARGET)
+ $(INSTALL) -c -m 644 nse_main.lua $(DESTDIR)$(nmapdatadir)/
+ $(INSTALL) -c -m 644 $(NSE_FILES) $(DESTDIR)$(nmapdatadir)/scripts
+ $(INSTALL) -c -m 644 $(NSE_LIB_LUA_FILES) $(DESTDIR)$(nmapdatadir)/nselib
+- $(INSTALL) -d $(DESTDIR)$(nmapdatadir)/nselib/data
++ -$(INSTALL) -d $(DESTDIR)$(nmapdatadir)/nselib/data
+ for f in `find nselib/data -name .svn -prune -o -type d -print`; do \
+ $(INSTALL) -d $(DESTDIR)$(nmapdatadir)/$$f; \
+ done
+diff --git a/nping/Makefile.in b/nping/Makefile.in
+index 3cf9c55..0db9ea5 100644
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -124,7 +124,7 @@ distclean: clean
+ stamp-h.in config.cache config.log config.status
+
+ install-nping: $(TARGET)
+- $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
++ -$(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -c -m 755 nping $(DESTDIR)$(bindir)/nping
+ # Use strip -x to avoid stripping dynamically loaded NSE functions. See
+ # http://seclists.org/nmap-dev/2007/q4/0272.html.
diff --git a/debian/patches/series b/debian/patches/series
index acae44b..35fb731 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,4 @@
+0001-use-su-to-root.patch
0002-Use-Debian-s-ca-certificates.patch
+0003-Make-uninstaller-not-fail-on-unparseable-versions.patch
+0004-Ignore-errors-of-install-d-invocations.patch