summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules4
3 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1730e19..e90276a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+nmap (7.94+git20230807.3be01efb1+dfsg-4) unstable; urgency=medium
+
+ [ Hilko Bengen ]
+ * Add missing zenmap dependency.
+ Thanks to Yadd <yadd@debian.org> (Closes: #1063824)
+
+ [ Antonio Terceiro ]
+ * debian/rules: filter out build flag not supported by i686-w64-mingw32-gcc
+ (Closes: #1069391)
+
+ -- Antonio Terceiro <terceiro@debian.org> Tue, 04 Jun 2024 13:40:09 -0300
+
nmap (7.94+git20230807.3be01efb1+dfsg-3~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/control b/debian/control
index 205e0c3..1ebe738 100644
--- a/debian/control
+++ b/debian/control
@@ -74,6 +74,7 @@ Architecture: all
Depends: ndiff,
nmap,
python3-gi,
+ python3-gi-cairo,
gir1.2-gtk-3.0,
gir1.2-pango-1.0,
gir1.2-glib-2.0,
diff --git a/debian/rules b/debian/rules
index 3b85558..a0c09b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,13 +22,15 @@ override_dh_auto_configure:
dh_auto_configure --sourcedir=ndiff --buildsystem=pybuild
dh_auto_configure --sourcedir=zenmap --buildsystem=pybuild
+mingw_CFLAGS = $(filter-out -mbranch-protection=standard,$(CFLAGS))
+
override_dh_auto_build-indep:
dh_auto_build
dh_auto_build --sourcedir=ndiff --buildsystem=pybuild
dh_auto_build --sourcedir=zenmap --buildsystem=pybuild
cd nselib/data/jdwp-class && /usr/lib/jvm/default-java/bin/javac *.java
cd nselib/data/psexec && \
- i686-w64-mingw32-gcc ${CPPFLAGS} ${CFLAGS} -o nmap_service.exe nmap_service.c && \
+ i686-w64-mingw32-gcc ${CPPFLAGS} ${mingw_CFLAGS} -o nmap_service.exe nmap_service.c && \
gzip -c -n9 nmap_service.exe | base64 | tac > nmap_service.ex_
override_dh_auto_test: