summaryrefslogtreecommitdiffstats
path: root/debian/tests/test_modules/abort-controller/dist
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 20:56:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 20:56:20 +0000
commit868522aa377a4519adb0b9f402586ab7a41b86ba (patch)
tree44e805e154a3ace9bd8dbac73843e80d296b7814 /debian/tests/test_modules/abort-controller/dist
parentAdding upstream version 5.28.2+dfsg1+~cs23.11.12.3. (diff)
downloadnode-undici-debian.tar.xz
node-undici-debian.zip
Adding debian version 5.28.2+dfsg1+~cs23.11.12.3-6.debian/5.28.2+dfsg1+_cs23.11.12.3-6debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/tests/test_modules/abort-controller/dist')
-rw-r--r--debian/tests/test_modules/abort-controller/dist/abort-controller.d.ts43
-rw-r--r--debian/tests/test_modules/abort-controller/dist/abort-controller.js127
-rw-r--r--debian/tests/test_modules/abort-controller/dist/abort-controller.mjs118
3 files changed, 288 insertions, 0 deletions
diff --git a/debian/tests/test_modules/abort-controller/dist/abort-controller.d.ts b/debian/tests/test_modules/abort-controller/dist/abort-controller.d.ts
new file mode 100644
index 0000000..75852fb
--- /dev/null
+++ b/debian/tests/test_modules/abort-controller/dist/abort-controller.d.ts
@@ -0,0 +1,43 @@
+import { EventTarget } from "event-target-shim"
+
+type Events = {
+ abort: any
+}
+type EventAttributes = {
+ onabort: any
+}
+/**
+ * The signal class.
+ * @see https://dom.spec.whatwg.org/#abortsignal
+ */
+declare class AbortSignal extends EventTarget<Events, EventAttributes> {
+ /**
+ * AbortSignal cannot be constructed directly.
+ */
+ constructor()
+ /**
+ * Returns `true` if this `AbortSignal`"s `AbortController` has signaled to abort, and `false` otherwise.
+ */
+ readonly aborted: boolean
+}
+/**
+ * The AbortController.
+ * @see https://dom.spec.whatwg.org/#abortcontroller
+ */
+declare class AbortController {
+ /**
+ * Initialize this controller.
+ */
+ constructor()
+ /**
+ * Returns the `AbortSignal` object associated with this object.
+ */
+ readonly signal: AbortSignal
+ /**
+ * Abort and signal to any observers that the associated activity is to be aborted.
+ */
+ abort(): void
+}
+
+export default AbortController
+export { AbortController, AbortSignal }
diff --git a/debian/tests/test_modules/abort-controller/dist/abort-controller.js b/debian/tests/test_modules/abort-controller/dist/abort-controller.js
new file mode 100644
index 0000000..49af739
--- /dev/null
+++ b/debian/tests/test_modules/abort-controller/dist/abort-controller.js
@@ -0,0 +1,127 @@
+/**
+ * @author Toru Nagashima <https://github.com/mysticatea>
+ * See LICENSE file in root directory for full license.
+ */
+'use strict';
+
+Object.defineProperty(exports, '__esModule', { value: true });
+
+var eventTargetShim = require('event-target-shim');
+
+/**
+ * The signal class.
+ * @see https://dom.spec.whatwg.org/#abortsignal
+ */
+class AbortSignal extends eventTargetShim.EventTarget {
+ /**
+ * AbortSignal cannot be constructed directly.
+ */
+ constructor() {
+ super();
+ throw new TypeError("AbortSignal cannot be constructed directly");
+ }
+ /**
+ * Returns `true` if this `AbortSignal`'s `AbortController` has signaled to abort, and `false` otherwise.
+ */
+ get aborted() {
+ const aborted = abortedFlags.get(this);
+ if (typeof aborted !== "boolean") {
+ throw new TypeError(`Expected 'this' to be an 'AbortSignal' object, but got ${this === null ? "null" : typeof this}`);
+ }
+ return aborted;
+ }
+}
+eventTargetShim.defineEventAttribute(AbortSignal.prototype, "abort");
+/**
+ * Create an AbortSignal object.
+ */
+function createAbortSignal() {
+ const signal = Object.create(AbortSignal.prototype);
+ eventTargetShim.EventTarget.call(signal);
+ abortedFlags.set(signal, false);
+ return signal;
+}
+/**
+ * Abort a given signal.
+ */
+function abortSignal(signal) {
+ if (abortedFlags.get(signal) !== false) {
+ return;
+ }
+ abortedFlags.set(signal, true);
+ signal.dispatchEvent({ type: "abort" });
+}
+/**
+ * Aborted flag for each instances.
+ */
+const abortedFlags = new WeakMap();
+// Properties should be enumerable.
+Object.defineProperties(AbortSignal.prototype, {
+ aborted: { enumerable: true },
+});
+// `toString()` should return `"[object AbortSignal]"`
+if (typeof Symbol === "function" && typeof Symbol.toStringTag === "symbol") {
+ Object.defineProperty(AbortSignal.prototype, Symbol.toStringTag, {
+ configurable: true,
+ value: "AbortSignal",
+ });
+}
+
+/**
+ * The AbortController.
+ * @see https://dom.spec.whatwg.org/#abortcontroller
+ */
+class AbortController {
+ /**
+ * Initialize this controller.
+ */
+ constructor() {
+ signals.set(this, createAbortSignal());
+ }
+ /**
+ * Returns the `AbortSignal` object associated with this object.
+ */
+ get signal() {
+ return getSignal(this);
+ }
+ /**
+ * Abort and signal to any observers that the associated activity is to be aborted.
+ */
+ abort() {
+ abortSignal(getSignal(this));
+ }
+}
+/**
+ * Associated signals.
+ */
+const signals = new WeakMap();
+/**
+ * Get the associated signal of a given controller.
+ */
+function getSignal(controller) {
+ const signal = signals.get(controller);
+ if (signal == null) {
+ throw new TypeError(`Expected 'this' to be an 'AbortController' object, but got ${controller === null ? "null" : typeof controller}`);
+ }
+ return signal;
+}
+// Properties should be enumerable.
+Object.defineProperties(AbortController.prototype, {
+ signal: { enumerable: true },
+ abort: { enumerable: true },
+});
+if (typeof Symbol === "function" && typeof Symbol.toStringTag === "symbol") {
+ Object.defineProperty(AbortController.prototype, Symbol.toStringTag, {
+ configurable: true,
+ value: "AbortController",
+ });
+}
+
+exports.AbortController = AbortController;
+exports.AbortSignal = AbortSignal;
+exports.default = AbortController;
+
+module.exports = AbortController
+module.exports.AbortController = module.exports["default"] = AbortController
+module.exports.AbortSignal = AbortSignal
+//# sourceMappingURL=abort-controller.js.map
diff --git a/debian/tests/test_modules/abort-controller/dist/abort-controller.mjs b/debian/tests/test_modules/abort-controller/dist/abort-controller.mjs
new file mode 100644
index 0000000..88ba22d
--- /dev/null
+++ b/debian/tests/test_modules/abort-controller/dist/abort-controller.mjs
@@ -0,0 +1,118 @@
+/**
+ * @author Toru Nagashima <https://github.com/mysticatea>
+ * See LICENSE file in root directory for full license.
+ */
+import { EventTarget, defineEventAttribute } from 'event-target-shim';
+
+/**
+ * The signal class.
+ * @see https://dom.spec.whatwg.org/#abortsignal
+ */
+class AbortSignal extends EventTarget {
+ /**
+ * AbortSignal cannot be constructed directly.
+ */
+ constructor() {
+ super();
+ throw new TypeError("AbortSignal cannot be constructed directly");
+ }
+ /**
+ * Returns `true` if this `AbortSignal`'s `AbortController` has signaled to abort, and `false` otherwise.
+ */
+ get aborted() {
+ const aborted = abortedFlags.get(this);
+ if (typeof aborted !== "boolean") {
+ throw new TypeError(`Expected 'this' to be an 'AbortSignal' object, but got ${this === null ? "null" : typeof this}`);
+ }
+ return aborted;
+ }
+}
+defineEventAttribute(AbortSignal.prototype, "abort");
+/**
+ * Create an AbortSignal object.
+ */
+function createAbortSignal() {
+ const signal = Object.create(AbortSignal.prototype);
+ EventTarget.call(signal);
+ abortedFlags.set(signal, false);
+ return signal;
+}
+/**
+ * Abort a given signal.
+ */
+function abortSignal(signal) {
+ if (abortedFlags.get(signal) !== false) {
+ return;
+ }
+ abortedFlags.set(signal, true);
+ signal.dispatchEvent({ type: "abort" });
+}
+/**
+ * Aborted flag for each instances.
+ */
+const abortedFlags = new WeakMap();
+// Properties should be enumerable.
+Object.defineProperties(AbortSignal.prototype, {
+ aborted: { enumerable: true },
+});
+// `toString()` should return `"[object AbortSignal]"`
+if (typeof Symbol === "function" && typeof Symbol.toStringTag === "symbol") {
+ Object.defineProperty(AbortSignal.prototype, Symbol.toStringTag, {
+ configurable: true,
+ value: "AbortSignal",
+ });
+}
+
+/**
+ * The AbortController.
+ * @see https://dom.spec.whatwg.org/#abortcontroller
+ */
+class AbortController {
+ /**
+ * Initialize this controller.
+ */
+ constructor() {
+ signals.set(this, createAbortSignal());
+ }
+ /**
+ * Returns the `AbortSignal` object associated with this object.
+ */
+ get signal() {
+ return getSignal(this);
+ }
+ /**
+ * Abort and signal to any observers that the associated activity is to be aborted.
+ */
+ abort() {
+ abortSignal(getSignal(this));
+ }
+}
+/**
+ * Associated signals.
+ */
+const signals = new WeakMap();
+/**
+ * Get the associated signal of a given controller.
+ */
+function getSignal(controller) {
+ const signal = signals.get(controller);
+ if (signal == null) {
+ throw new TypeError(`Expected 'this' to be an 'AbortController' object, but got ${controller === null ? "null" : typeof controller}`);
+ }
+ return signal;
+}
+// Properties should be enumerable.
+Object.defineProperties(AbortController.prototype, {
+ signal: { enumerable: true },
+ abort: { enumerable: true },
+});
+if (typeof Symbol === "function" && typeof Symbol.toStringTag === "symbol") {
+ Object.defineProperty(AbortController.prototype, Symbol.toStringTag, {
+ configurable: true,
+ value: "AbortController",
+ });
+}
+
+export default AbortController;
+export { AbortController, AbortSignal };
+//# sourceMappingURL=abort-controller.mjs.map