summaryrefslogtreecommitdiffstats
path: root/test/wpt/tests/xhr/open-url-multi-window-5.htm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 20:56:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 20:56:19 +0000
commit0b6210cd37b68b94252cb798598b12974a20e1c1 (patch)
treee371686554a877842d95aa94f100bee552ff2a8e /test/wpt/tests/xhr/open-url-multi-window-5.htm
parentInitial commit. (diff)
downloadnode-undici-upstream.tar.xz
node-undici-upstream.zip
Adding upstream version 5.28.2+dfsg1+~cs23.11.12.3.upstream/5.28.2+dfsg1+_cs23.11.12.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/wpt/tests/xhr/open-url-multi-window-5.htm')
-rw-r--r--test/wpt/tests/xhr/open-url-multi-window-5.htm32
1 files changed, 32 insertions, 0 deletions
diff --git a/test/wpt/tests/xhr/open-url-multi-window-5.htm b/test/wpt/tests/xhr/open-url-multi-window-5.htm
new file mode 100644
index 0000000..32c467a
--- /dev/null
+++ b/test/wpt/tests/xhr/open-url-multi-window-5.htm
@@ -0,0 +1,32 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() resolving URLs (multi-Window; 5)</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[2]/ol[1]/li[1]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ var test = async_test(),
+ client,
+ exceptionCtor,
+ count = 0;
+ function init() {
+ test.step(function() {
+ if(0 == count) {
+ client = new self[0].XMLHttpRequest();
+ exceptionCtor = self[0].DOMException;
+ count++
+ self[0].location.reload()
+ } else if(1 == count) {
+ assert_throws_dom("InvalidStateError", exceptionCtor, function() {client.open("GET", "...") });
+ test.done()
+ }
+ })
+ }
+ </script>
+ <iframe src="resources/init.htm"></iframe>
+ </body>
+</html>