summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-20 17:12:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-20 17:12:42 +0000
commitc332a500d10e424219cd2c7285c27e7cad30634b (patch)
tree34f3d9e1ef1d0f452b8ec3d4bf31b34cd702302f /debian/rules
parentAdding upstream version 20221223. (diff)
downloadopen-infrastructure-compute-tools-debian.tar.xz
open-infrastructure-compute-tools-debian.zip
Adding debian version 20221223-5.debian/20221223-5debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f543379
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+PACKAGE := open-infrastructure-compute-tools
+
+%:
+ dh ${@}
+
+override_dh_auto_build:
+ # disabled
+
+override_dh_auto_install:
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/$(PACKAGE)
+
+execute_after_dh_auto_install:
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/CHANGELOG.txt
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/LICENSE.txt
+
+ mv debian/$(PACKAGE)/usr/share/doc/* debian/$(PACKAGE)/usr/share/doc/$(PACKAGE)
+
+override_dh_installsystemd:
+ dh_installsystemd --no-restart-after-upgrade --no-start --no-stop-on-upgrade