summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:22:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:22:28 +0000
commit07b1e3bdb87c5d752dd09ccd778ab476c4b84c6e (patch)
tree4484114a577eb870fea118e78b011915561ddce8 /debian/rules
parentReleasing progress-linux version 1:9.7p1-2~progress7.99u1. (diff)
downloadopenssh-07b1e3bdb87c5d752dd09ccd778ab476c4b84c6e.tar.xz
openssh-07b1e3bdb87c5d752dd09ccd778ab476c4b84c6e.zip
Merging debian version 1:9.7p1-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 0 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index f3fa87f..6184bef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,10 +108,6 @@ ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes) $(DEB_HOST_ARCH), yes i386)
BUILD_PACKAGES += -Nopenssh-tests
endif
-ifeq ($(DEB_HOST_ARCH_BITS)$(filter i386,$(DEB_HOST_ARCH_CPU)),32)
- BUILD_PACKAGES += -Nssh-askpass-gnome
-endif
-
%:
dh $@ --with=runit $(BUILD_PACKAGES)
@@ -136,11 +132,9 @@ ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
$(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen
endif
-ifneq ($(DEB_HOST_ARCH_BITS)$(filter i386,$(DEB_HOST_ARCH_CPU)),32)
ifeq ($(filter pkg.openssh.nognome,$(DEB_BUILD_PROFILES)),)
$(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG)
endif
-endif
override_dh_auto_build-indep: