summaryrefslogtreecommitdiffstats
path: root/debian/patches/restore-tcp-wrappers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/restore-tcp-wrappers.patch')
-rw-r--r--debian/patches/restore-tcp-wrappers.patch78
1 files changed, 39 insertions, 39 deletions
diff --git a/debian/patches/restore-tcp-wrappers.patch b/debian/patches/restore-tcp-wrappers.patch
index ee53872..7ea30ff 100644
--- a/debian/patches/restore-tcp-wrappers.patch
+++ b/debian/patches/restore-tcp-wrappers.patch
@@ -1,4 +1,4 @@
-From f6856e554804e6bd6c93fb48bea73a26f912ad7f Mon Sep 17 00:00:00 2001
+From 33df9974b50dda9718f7e31ca8568432edd97168 Mon Sep 17 00:00:00 2001
From: Colin Watson <cjwatson@debian.org>
Date: Tue, 7 Oct 2014 13:22:41 +0100
Subject: Restore TCP wrappers support
@@ -18,20 +18,20 @@ but it at least probably doesn't involve dropping this feature shortly
before a freeze.
Forwarded: not-needed
-Last-Update: 2022-02-23
+Last-Update: 2024-07-03
Patch-Name: restore-tcp-wrappers.patch
---
- configure.ac | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++++
- sshd.8 | 7 +++++++
- sshd.c | 25 +++++++++++++++++++++++
+ configure.ac | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++
+ sshd-session.c | 25 ++++++++++++++++++++++
+ sshd.8 | 7 +++++++
3 files changed, 89 insertions(+)
diff --git a/configure.ac b/configure.ac
-index bb3e644fe..2b2c4f086 100644
+index dc274329f..f6bca2631 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1685,6 +1685,62 @@ else
+@@ -1686,6 +1686,62 @@ else
AC_MSG_RESULT([no])
fi
@@ -94,7 +94,7 @@ index bb3e644fe..2b2c4f086 100644
# Check whether user wants to use ldns
LDNS_MSG="no"
AC_ARG_WITH(ldns,
-@@ -5707,6 +5763,7 @@ echo " PAM support: $PAM_MSG"
+@@ -5723,6 +5779,7 @@ echo " PAM support: $PAM_MSG"
echo " OSF SIA support: $SIA_MSG"
echo " KerberosV support: $KRB5_MSG"
echo " SELinux support: $SELINUX_MSG"
@@ -102,36 +102,11 @@ index bb3e644fe..2b2c4f086 100644
echo " libedit support: $LIBEDIT_MSG"
echo " libldns support: $LDNS_MSG"
echo " Solaris process contract support: $SPC_MSG"
-diff --git a/sshd.8 b/sshd.8
-index 73d5e9232..8efeacdf1 100644
---- a/sshd.8
-+++ b/sshd.8
-@@ -924,6 +924,12 @@ the user's home directory becomes accessible.
- This file should be writable only by the user, and need not be
- readable by anyone else.
- .Pp
-+.It Pa /etc/hosts.allow
-+.It Pa /etc/hosts.deny
-+Access controls that should be enforced by tcp-wrappers are defined here.
-+Further details are described in
-+.Xr hosts_access 5 .
-+.Pp
- .It Pa /etc/hosts.equiv
- This file is for host-based authentication (see
- .Xr ssh 1 ) .
-@@ -1026,6 +1032,7 @@ The content of this file is not sensitive; it can be world-readable.
- .Xr ssh-keygen 1 ,
- .Xr ssh-keyscan 1 ,
- .Xr chroot 2 ,
-+.Xr hosts_access 5 ,
- .Xr login.conf 5 ,
- .Xr moduli 5 ,
- .Xr sshd_config 5 ,
-diff --git a/sshd.c b/sshd.c
-index d5c3dfe57..87e25d19b 100644
---- a/sshd.c
-+++ b/sshd.c
-@@ -128,6 +128,13 @@
+diff --git a/sshd-session.c b/sshd-session.c
+index ab88db7c5..a9fa63224 100644
+--- a/sshd-session.c
++++ b/sshd-session.c
+@@ -110,6 +110,13 @@
#include "srclimit.h"
#include "dh.h"
@@ -145,7 +120,7 @@ index d5c3dfe57..87e25d19b 100644
/* Re-exec fds */
#define REEXEC_DEVCRYPTO_RESERVED_FD (STDERR_FILENO + 1)
#define REEXEC_STARTUP_PIPE_FD (STDERR_FILENO + 2)
-@@ -2200,6 +2207,24 @@ main(int ac, char **av)
+@@ -1254,6 +1261,24 @@ main(int ac, char **av)
#ifdef SSH_AUDIT_EVENTS
audit_connection_from(remote_ip, remote_port);
#endif
@@ -170,3 +145,28 @@ index d5c3dfe57..87e25d19b 100644
rdomain = ssh_packet_rdomain_in(ssh);
+diff --git a/sshd.8 b/sshd.8
+index c0f095ca4..e2a621950 100644
+--- a/sshd.8
++++ b/sshd.8
+@@ -921,6 +921,12 @@ the user's home directory becomes accessible.
+ This file should be writable only by the user, and need not be
+ readable by anyone else.
+ .Pp
++.It Pa /etc/hosts.allow
++.It Pa /etc/hosts.deny
++Access controls that should be enforced by tcp-wrappers are defined here.
++Further details are described in
++.Xr hosts_access 5 .
++.Pp
+ .It Pa /etc/hosts.equiv
+ This file is for host-based authentication (see
+ .Xr ssh 1 ) .
+@@ -1023,6 +1029,7 @@ The content of this file is not sensitive; it can be world-readable.
+ .Xr ssh-keygen 1 ,
+ .Xr ssh-keyscan 1 ,
+ .Xr chroot 2 ,
++.Xr hosts_access 5 ,
+ .Xr login.conf 5 ,
+ .Xr moduli 5 ,
+ .Xr sshd_config 5 ,