summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:30 +0000
commite29ea357f2f9d6352f60974b49bc0216bf954b35 (patch)
tree15c268b0e6b77a995cacbe7d95e09c2f2346de51 /debian/patches
parentMerging upstream version 2.1.8~rc1. (diff)
downloadpacemaker-e29ea357f2f9d6352f60974b49bc0216bf954b35.tar.xz
pacemaker-e29ea357f2f9d6352f60974b49bc0216bf954b35.zip
Merging debian version 2.1.8~rc1-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/Always-format-time_t-values-as-long-long.patch37
-rw-r--r--debian/patches/Always-run-Inkscape-under-the-C.UTF-8-locale.patch2
-rw-r--r--debian/patches/Fix-typos-resouce-resource.patch30
-rw-r--r--debian/patches/Remove-references-to-the-build-directory.patch20
-rw-r--r--debian/patches/cts-do-not-capture-the-build-directory.patch4
-rw-r--r--debian/patches/series1
6 files changed, 29 insertions, 65 deletions
diff --git a/debian/patches/Always-format-time_t-values-as-long-long.patch b/debian/patches/Always-format-time_t-values-as-long-long.patch
deleted file mode 100644
index afcad60..0000000
--- a/debian/patches/Always-format-time_t-values-as-long-long.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From: =?utf-8?q?Ferenc_W=C3=A1gner?= <wferi@debian.org>
-Date: Fri, 22 Mar 2024 16:40:07 +0100
-Subject: Always format time_t values as long long
-MIME-Version: 1.0
-Content-Type: text/plain; charset="utf-8"
-Content-Transfer-Encoding: 8bit
-
-Conventionally it's signed long under the GNU C library, which is 32
-bits on 32-bit architectures, but Glibc provides the __TIME_BITS==64
-option, which makes it signed long long instead (64 bits) and makes no
-difference on 64-bit architectures [1]. This enables using the %llu
-conversion specifier uniformly across all supported architectures.
-This got exposed by Debian recently transitioning to 64-bit time_t [2].
-
-[1] https://sourceware.org/glibc/wiki/Y2038ProofnessDesign
-[2] https://wiki.debian.org/ReleaseGoals/64bit-time
-
-Signed-off-by: Ferenc Wágner <wferi@debian.org>
----
- daemons/fenced/fenced_remote.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/daemons/fenced/fenced_remote.c b/daemons/fenced/fenced_remote.c
-index 843b3d4..9616e8e 100644
---- a/daemons/fenced/fenced_remote.c
-+++ b/daemons/fenced/fenced_remote.c
-@@ -1042,8 +1042,8 @@ merge_duplicates(remote_fencing_op_t *op)
- }
- if ((other->total_timeout > 0)
- && (now > (other->total_timeout + other->created))) {
-- crm_trace("%.8s not duplicate of %.8s: old (%ld vs. %ld + %d)",
-- op->id, other->id, now, other->created,
-+ crm_trace("%.8s not duplicate of %.8s: old (%lld vs. %lld + %d)",
-+ op->id, other->id, (long long)now, (long long)other->created,
- other->total_timeout);
- continue;
- }
diff --git a/debian/patches/Always-run-Inkscape-under-the-C.UTF-8-locale.patch b/debian/patches/Always-run-Inkscape-under-the-C.UTF-8-locale.patch
index 076daac..1546187 100644
--- a/debian/patches/Always-run-Inkscape-under-the-C.UTF-8-locale.patch
+++ b/debian/patches/Always-run-Inkscape-under-the-C.UTF-8-locale.patch
@@ -7,7 +7,7 @@ Subject: Always run Inkscape under the C.UTF-8 locale
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/doc/sphinx/Makefile.am b/doc/sphinx/Makefile.am
-index e48e19a..54e2896 100644
+index b95f47b..4c35f00 100644
--- a/doc/sphinx/Makefile.am
+++ b/doc/sphinx/Makefile.am
@@ -104,7 +104,7 @@ DEPS_Pacemaker_Remote = $(PNGS_Pacemaker_Remote)
diff --git a/debian/patches/Fix-typos-resouce-resource.patch b/debian/patches/Fix-typos-resouce-resource.patch
index 7f3ed87..9ec45e7 100644
--- a/debian/patches/Fix-typos-resouce-resource.patch
+++ b/debian/patches/Fix-typos-resouce-resource.patch
@@ -21,24 +21,24 @@ index a89eb0e..be19d07 100644
common_cmds = self._common_cmds
# do not use service and systemd at the same time, it is the same resource.
diff --git a/lib/pacemaker/pcmk_sched_primitive.c b/lib/pacemaker/pcmk_sched_primitive.c
-index 96acf1c..91adbff 100644
+index a113cca..9e4961a 100644
--- a/lib/pacemaker/pcmk_sched_primitive.c
+++ b/lib/pacemaker/pcmk_sched_primitive.c
-@@ -1326,7 +1326,7 @@ start_resource(pcmk_resource_t *rsc, pcmk_node_t *node, bool optional)
+@@ -1338,7 +1338,7 @@ start_resource(pcmk_resource_t *rsc, pcmk_node_t *node, bool optional)
* reasons later.
*/
- pe_rsc_trace(rsc,
-- "Start of multiply active resouce %s "
-+ "Start of multiply active resource %s "
- "on expected node %s will be a pseudo-action",
- rsc->id, pe__node_name(node));
- pe__set_action_flags(start, pcmk_action_pseudo);
-@@ -1373,7 +1373,7 @@ promote_resource(pcmk_resource_t *rsc, pcmk_node_t *node, bool optional)
+ pcmk__rsc_trace(rsc,
+- "Start of multiply active resouce %s "
++ "Start of multiply active resource %s "
+ "on expected node %s will be a pseudo-action",
+ rsc->id, pcmk__node_name(node));
+ pcmk__set_action_flags(start, pcmk_action_pseudo);
+@@ -1385,7 +1385,7 @@ promote_resource(pcmk_resource_t *rsc, pcmk_node_t *node, bool optional)
* other reasons later.
*/
- pe_rsc_trace(rsc,
-- "Promotion of multiply active resouce %s "
-+ "Promotion of multiply active resource %s "
- "on expected node %s will be a pseudo-action",
- rsc->id, pe__node_name(node));
- pe__set_action_flags(promote, pcmk_action_pseudo);
+ pcmk__rsc_trace(rsc,
+- "Promotion of multiply active resouce %s "
++ "Promotion of multiply active resource %s "
+ "on expected node %s will be a pseudo-action",
+ rsc->id, pcmk__node_name(node));
+ pcmk__set_action_flags(promote, pcmk_action_pseudo);
diff --git a/debian/patches/Remove-references-to-the-build-directory.patch b/debian/patches/Remove-references-to-the-build-directory.patch
index 30c6321..7671783 100644
--- a/debian/patches/Remove-references-to-the-build-directory.patch
+++ b/debian/patches/Remove-references-to-the-build-directory.patch
@@ -7,8 +7,8 @@ directory can be solved by setting environment variables.
---
agents/stonith/fence_legacy.in | 9 ---------
mk/man.mk | 12 +++++++-----
- python/pacemaker/buildoptions.py.in | 6 ------
- 3 files changed, 7 insertions(+), 20 deletions(-)
+ python/pacemaker/buildoptions.py.in | 8 --------
+ 3 files changed, 7 insertions(+), 22 deletions(-)
diff --git a/agents/stonith/fence_legacy.in b/agents/stonith/fence_legacy.in
index c0eeca1..7583986 100755
@@ -65,19 +65,21 @@ index 51dd1e6..ccd8730 100644
$(abs_builddir)/$< --output $@ ; \
fi
diff --git a/python/pacemaker/buildoptions.py.in b/python/pacemaker/buildoptions.py.in
-index 17fe981..3bb85c1 100644
+index a97640c..d66a691 100644
--- a/python/pacemaker/buildoptions.py.in
+++ b/python/pacemaker/buildoptions.py.in
-@@ -13,12 +13,6 @@ class BuildOptions:
+@@ -16,14 +16,6 @@ class BuildOptions:
BASH_PATH = "@BASH_PATH@"
- """ Path to the bash shell """
+ """Path to the bash shell."""
- _BUILD_DIR = "@abs_top_builddir@"
-- """ Top-level build directory
-- NOTE: This is not especially useful on installed systems, but is useful for
-- running various programs from a source checkout
+- """
+- Top-level build directory.
+-
+- NOTE: This is not especially useful on installed systems, but is useful for
+- running various programs from a source checkout
- """
-
CIB_DIR = "@CRM_CONFIG_DIR@"
- """ Where CIB files are stored """
+ """Where CIB files are stored."""
diff --git a/debian/patches/cts-do-not-capture-the-build-directory.patch b/debian/patches/cts-do-not-capture-the-build-directory.patch
index f36112a..cbf1590 100644
--- a/debian/patches/cts-do-not-capture-the-build-directory.patch
+++ b/debian/patches/cts-do-not-capture-the-build-directory.patch
@@ -11,7 +11,7 @@ Subject: cts: do not capture the build directory
5 files changed, 46 deletions(-)
diff --git a/cts/cts-attrd.in b/cts/cts-attrd.in
-index b594ac3..f0cba42 100644
+index c9a219d..f187f7d 100644
--- a/cts/cts-attrd.in
+++ b/cts/cts-attrd.in
@@ -17,16 +17,6 @@ import subprocess
@@ -52,7 +52,7 @@ index be19d07..acd10af 100644
from pacemaker.exitstatus import ExitStatus
from pacemaker._cts.errors import ExitCodeError, OutputFoundError, OutputNotFoundError
diff --git a/cts/cts-fencing.in b/cts/cts-fencing.in
-index c2ed29a..99a1286 100644
+index 6785144..29dbac5 100644
--- a/cts/cts-fencing.in
+++ b/cts/cts-fencing.in
@@ -11,15 +11,6 @@ import sys
diff --git a/debian/patches/series b/debian/patches/series
index fb12979..0ad30a0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,4 +7,3 @@ Fix-typos-resouce-resource.patch
Remove-references-to-the-build-directory.patch
cts-do-not-capture-the-build-directory.patch
python-clean-up-the-__pycache__-directories.patch
-Always-format-time_t-values-as-long-long.patch