summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:29 +0000
commitd227a9891bbe76a1216d410b963b8543c19fcd20 (patch)
tree09f79e65a296ed46451567b7ea213431e12b80d1 /debian
parentReleasing progress-linux version 2.1.6-4.1~progress7.99u1. (diff)
downloadpacemaker-d227a9891bbe76a1216d410b963b8543c19fcd20.tar.xz
pacemaker-d227a9891bbe76a1216d410b963b8543c19fcd20.zip
Merging debian version 2.1.6-5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/Always-format-time_t-values-as-long-long.patch37
-rw-r--r--debian/patches/series1
4 files changed, 47 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bcecf2e..46a2ea7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pacemaker (2.1.6-5) unstable; urgency=medium
+
+ * [fba0e62] Annotate the versioned dpkg-dev build dependency with time64
+ * [2e0223d] New patch: Always format time_t values as long long
+ * [8b575c7] pkgconf superseded pkg-config
+
+ -- Ferenc Wágner <wferi@debian.org> Fri, 22 Mar 2024 17:48:44 +0100
+
pacemaker (2.1.6-4.1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/control b/debian/control
index 32af3ed..3f8b3f2 100644
--- a/debian/control
+++ b/debian/control
@@ -33,7 +33,7 @@ Build-Depends:
libxml2-dev,
libxml2-utils,
libxslt1-dev,
- pkg-config,
+ pkgconf,
# 'pacemaker' is a pure Python package:
python3-all,
systemd [linux-any],
diff --git a/debian/patches/Always-format-time_t-values-as-long-long.patch b/debian/patches/Always-format-time_t-values-as-long-long.patch
new file mode 100644
index 0000000..444991b
--- /dev/null
+++ b/debian/patches/Always-format-time_t-values-as-long-long.patch
@@ -0,0 +1,37 @@
+From: =?utf-8?q?Ferenc_W=C3=A1gner?= <wferi@debian.org>
+Date: Fri, 22 Mar 2024 16:40:07 +0100
+Subject: Always format time_t values as long long
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Conventionally it's signed long under the GNU C library, which is 32
+bits on 32-bit architectures, but Glibc provides the __TIME_BITS==64
+option, which makes it signed long long instead (64 bits) and makes no
+difference on 64-bit architectures [1]. This enables using the %llu
+conversion specifier uniformly across all supported architectures.
+This got exposed by Debian recently transitioning to 64-bit time_t [2].
+
+[1] https://sourceware.org/glibc/wiki/Y2038ProofnessDesign
+[2] https://wiki.debian.org/ReleaseGoals/64bit-time
+
+Signed-off-by: Ferenc Wágner <wferi@debian.org>
+---
+ daemons/fenced/fenced_remote.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/daemons/fenced/fenced_remote.c b/daemons/fenced/fenced_remote.c
+index dc67947..ef2237a 100644
+--- a/daemons/fenced/fenced_remote.c
++++ b/daemons/fenced/fenced_remote.c
+@@ -1042,8 +1042,8 @@ merge_duplicates(remote_fencing_op_t *op)
+ }
+ if ((other->total_timeout > 0)
+ && (now > (other->total_timeout + other->created))) {
+- crm_trace("%.8s not duplicate of %.8s: old (%ld vs. %ld + %d)",
+- op->id, other->id, now, other->created,
++ crm_trace("%.8s not duplicate of %.8s: old (%lld vs. %lld + %d)",
++ op->id, other->id, (long long)now, (long long)other->created,
+ other->total_timeout);
+ continue;
+ }
diff --git a/debian/patches/series b/debian/patches/series
index 0ad30a0..fb12979 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ Fix-typos-resouce-resource.patch
Remove-references-to-the-build-directory.patch
cts-do-not-capture-the-build-directory.patch
python-clean-up-the-__pycache__-directories.patch
+Always-format-time_t-values-as-long-long.patch