summaryrefslogtreecommitdiffstats
path: root/devel/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:29 +0000
commitb41961d74fe7ff2d4d4abaca92454e87c561e49f (patch)
treeb34e3826a7b649dafdbd05081140c990c96d736d /devel/Makefile.am
parentReleasing progress-linux version 2.1.7-1~progress7.99u1. (diff)
downloadpacemaker-b41961d74fe7ff2d4d4abaca92454e87c561e49f.tar.xz
pacemaker-b41961d74fe7ff2d4d4abaca92454e87c561e49f.zip
Merging upstream version 2.1.8~rc1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'devel/Makefile.am')
-rw-r--r--devel/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/Makefile.am b/devel/Makefile.am
index b50f097..15012f6 100644
--- a/devel/Makefile.am
+++ b/devel/Makefile.am
@@ -165,6 +165,8 @@ coverity-clean:
## cppcheck
GLIB_CFLAGS ?= $(pkg-config --cflags glib-2.0)
+GLIB_INCL_DEF_CFLAGS = $(shell echo $(GLIB_CFLAGS) \
+ | tr ' ' '\n' | grep '^-[IDU]' | paste -d ' ')
# Use CPPCHECK_ARGS to pass extra cppcheck options, e.g.:
# --enable={warning,style,performance,portability,information,all}
@@ -181,7 +183,7 @@ cppcheck:
--output-file=$(CPPCHECK_OUT) \
--max-configs=30 --inline-suppr -q \
--library=posix --library=gnu --library=gtk \
- $(GLIB_CFLAGS) -D__GNUC__ \
+ $(GLIB_INCL_DEF_CFLAGS) -D__GNUC__ \
$(foreach dir,$(CPPCHECK_DIRS),$(top_srcdir)/$(dir))
@echo "Done: See $(CPPCHECK_OUT)"
@echo "When no longer needed, make cppcheck-clean"