summaryrefslogtreecommitdiffstats
path: root/doc/abi-check.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
commit07d7f4cfa4b10de87a31b68191036ff446add675 (patch)
tree7162524d8aaf1aef62d2f4fa51f595ed113981ff /doc/abi-check.in
parentAdding upstream version 2.1.6. (diff)
downloadpacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.tar.xz
pacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.zip
Adding upstream version 2.1.7.upstream/2.1.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/abi-check.in')
-rwxr-xr-xdoc/abi-check.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/doc/abi-check.in b/doc/abi-check.in
index 5a5e253..6b6a8d3 100755
--- a/doc/abi-check.in
+++ b/doc/abi-check.in
@@ -1,6 +1,6 @@
#!@BASH_PATH@
#
-# Copyright 2011-2022 the Pacemaker project contributors
+# Copyright 2011-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -29,6 +29,12 @@ tag() {
fi
}
+sed_in_place() {
+ cp -p "$1" "$1.$$"
+ sed -e "$2" "$1" > "$1.$$"
+ mv "$1.$$" "$1"
+}
+
# Strip anything up to and including a dash from the argument
version() {
echo "$1" | sed s:.*-::
@@ -103,7 +109,7 @@ extract_one() {
# Remove "doc" from SUBDIRS in Makefile (but why?)
BUILD_ROOT="$(pwd)/$BUILD_ROOT"
- sed -i.sed 's: doc::' "$BUILD_ROOT/Makefile.am"
+ sed_in_place "$BUILD_ROOT/Makefile.am" 's: doc::'
# Run ABI dump
abi_config "$PACKAGE" "$VERSION" "$BUILD_ROOT" "$DESC"