summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:46:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:46:09 +0000
commit043aa641ad4373e96fd748deb1e7fab3cb579a07 (patch)
treef8fde8a97ab5db152043f6c01043672114c0a4df /etc/Makefile.am
parentReleasing progress-linux version 2.1.6-5~progress7.99u1. (diff)
downloadpacemaker-043aa641ad4373e96fd748deb1e7fab3cb579a07.tar.xz
pacemaker-043aa641ad4373e96fd748deb1e7fab3cb579a07.zip
Merging upstream version 2.1.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index b810f82..b90bb50 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2021-2022 the Pacemaker project contributors
+# Copyright 2021-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -10,7 +10,8 @@
MAINTAINERCLEANFILES = Makefile.in
configdir = @CONFIGDIR@
-CONFIGS = crm_mon pacemaker
+CONFIGS = crm_mon \
+ pacemaker
if !BUILD_SYSTEMD
initdir = $(INITDIR)
@@ -23,6 +24,7 @@ logrotate_DATA = logrotate.d/pacemaker
EXTRA_DIST = $(foreach f,$(CONFIGS),sysconfig/$(f))
# Don't overwrite user's existing config files
+.PHONY: install-data-local
install-data-local:
$(AM_V_at)$(MKDIR_P) $(DESTDIR)$(configdir)
$(AM_V_at)for f in $(CONFIGS); do \
@@ -31,6 +33,7 @@ install-data-local:
$(INSTALL_DATA) "$(srcdir)/sysconfig/$$f" "$$dest"; \
done
+.PHONY: uninstall-local
uninstall-local:
$(AM_V_at)for f in $(CONFIGS); do \
dest="$(DESTDIR)$(configdir)/$$f"; \