summaryrefslogtreecommitdiffstats
path: root/mk/unittest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
commite5a812082ae033afb1eed82c0f2df3d0f6bdc93f (patch)
treea6716c9275b4b413f6c9194798b34b91affb3cc7 /mk/unittest.mk
parentInitial commit. (diff)
downloadpacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.tar.xz
pacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.zip
Adding upstream version 2.1.6.upstream/2.1.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'mk/unittest.mk')
-rw-r--r--mk/unittest.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/mk/unittest.mk b/mk/unittest.mk
new file mode 100644
index 0000000..ea397f2
--- /dev/null
+++ b/mk/unittest.mk
@@ -0,0 +1,19 @@
+#
+# Copyright 2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+AM_CPPFLAGS = -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/lib/common
+
+AM_CFLAGS = -DPCMK__UNIT_TESTING
+
+AM_LDFLAGS = $(LDFLAGS_WRAP)
+
+LDADD = $(top_builddir)/lib/common/libcrmcommon_test.la \
+ -lcmocka