summaryrefslogtreecommitdiffstats
path: root/rpm/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:39:28 +0000
commit924f5ea83e48277e014ebf0d19a27187cb93e2f7 (patch)
tree75920a275bba045f6d108204562c218a9a26ea15 /rpm/Makefile.am
parentAdding upstream version 2.1.7. (diff)
downloadpacemaker-upstream.tar.xz
pacemaker-upstream.zip
Adding upstream version 2.1.8~rc1.upstream/2.1.8_rc1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rpm/Makefile.am')
-rw-r--r--rpm/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/rpm/Makefile.am b/rpm/Makefile.am
index 2388ad6..9a454e5 100644
--- a/rpm/Makefile.am
+++ b/rpm/Makefile.am
@@ -162,7 +162,12 @@ $(RPM_SPEC_DIR)/$(PACKAGE).spec: spec-clean pacemaker.spec.in
-e 's/^\(%global commit_abbrev \).*/\1$(SPEC_ABBREV)/' \
-e "s/PACKAGE_DATE/$$(date +'%a %b %d %Y')/" \
-e 's/PACKAGE_VERSION/$(SPEC_RELEASE_NO)-$(SPECVERSION)/' \
- > "$@"
+ > "$@"; \
+ if echo "$$(rpmlint --help 2>&1)" | grep -q "ignore-unused-rpmlintrc"; then \
+ rpmlint --ignore-unused-rpmlintrc --file rpmlintrc "$@"; \
+ else \
+ rpmlint --file rpmlintrc "$@"; \
+ fi
.PHONY: spec $(PACKAGE).spec
spec $(PACKAGE).spec: $(RPM_SPEC_DIR)/$(PACKAGE).spec
@@ -191,10 +196,6 @@ rpm: srpm
rpm-clean: spec-clean srpm-clean
-if [ -n "$(RPM_CLEAN)" ]; then rm -rf $(RPM_CLEAN); fi
-.PHONY: rpmlint
-rpmlint: $(RPM_SPEC_DIR)/$(PACKAGE).spec
- rpmlint -f rpmlintrc "$<"
-
.PHONY: rpm-dep
rpm-dep: $(RPM_SPEC_DIR)/$(PACKAGE).spec
sudo yum-builddep "$(RPM_SPEC_DIR)/$(PACKAGE).spec"