summaryrefslogtreecommitdiffstats
path: root/debian/patches/python-clean-up-the-__pycache__-directories.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/python-clean-up-the-__pycache__-directories.patch')
-rw-r--r--debian/patches/python-clean-up-the-__pycache__-directories.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/python-clean-up-the-__pycache__-directories.patch b/debian/patches/python-clean-up-the-__pycache__-directories.patch
new file mode 100644
index 0000000..144e5b3
--- /dev/null
+++ b/debian/patches/python-clean-up-the-__pycache__-directories.patch
@@ -0,0 +1,31 @@
+From: =?utf-8?q?Ferenc_W=C3=A1gner?= <wferi@debian.org>
+Date: Tue, 26 Sep 2023 18:10:08 +0200
+Subject: python: clean up the __pycache__ directories
+
+---
+ python/pacemaker/Makefile.am | 3 +++
+ python/tests/Makefile.am | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/python/pacemaker/Makefile.am b/python/pacemaker/Makefile.am
+index f209bba..f722d48 100644
+--- a/python/pacemaker/Makefile.am
++++ b/python/pacemaker/Makefile.am
+@@ -15,3 +15,6 @@ pkgpython_PYTHON = __init__.py \
+ nodist_pkgpython_PYTHON = buildoptions.py
+
+ SUBDIRS = _cts
++
++clean-local:
++ rm -rf __pycache__
+diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
+index 490b272..6f93823 100644
+--- a/python/tests/Makefile.am
++++ b/python/tests/Makefile.am
+@@ -10,3 +10,6 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+ EXTRA_DIST = $(wildcard test_*)
++
++clean-local:
++ rm -rf __pycache__