summaryrefslogtreecommitdiffstats
path: root/debian/package-notes.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/package-notes.mk')
-rw-r--r--debian/package-notes.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/package-notes.mk b/debian/package-notes.mk
index 2cb1339..dc2c705 100644
--- a/debian/package-notes.mk
+++ b/debian/package-notes.mk
@@ -4,16 +4,14 @@
# llvm does not support spec files
ifeq ( ,$(filter lld, $(LD)))
+# Ubuntu implemented this in dpkg-buildpackage, make this a no-op to avoid duplication
+include /usr/share/dpkg/vendor.mk
+ifneq ($(DEB_VENDOR),Ubuntu)
# binutils 2.39 is required for --package-metadata=
ifeq (0, $(shell dpkg --compare-versions $$(dpkg-query -f '$${Version}' -W binutils) ge 2.39; echo $$?))
-include /usr/share/dpkg/vendor.mk
ifeq (, $(filter nocheck, $(DEBUGINFOD_URLS)))
-ifeq ($(DEB_VENDOR),Ubuntu)
-export DEBUGINFOD_URLS=https://debuginfod.ubuntu.com
-else
export DEBUGINFOD_URLS=https://debuginfod.debian.net
endif
-endif
export DEB_SOURCE_PACKAGE_VERSION=$(shell dpkg-parsechangelog -S Version)
export DEB_SOURCE_PACKAGE_NAME=$(shell dpkg-parsechangelog -S Source)
# Set by /usr/share/dpkg/vendor.mk
@@ -21,4 +19,5 @@ export DEB_VENDOR
export DEB_LDFLAGS_MAINT_APPEND+= -specs=/usr/share/debhelper/dh_package_notes/debian-package-notes.specs
endif
endif
+endif