summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..40ee871
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,14 @@
+AC_INIT([parallel],[20240222],[bug-parallel@gnu.org])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+
+AC_ARG_ENABLE(documentation,
+ AS_HELP_STRING([--disable-documentation],[Omit building and installing the documentation. (default=no)]),,
+ [enable_documentation=yes])
+AM_CONDITIONAL([DOCUMENTATION], [test x$enable_documentation = xyes])
+AC_PROG_LN_S
+AC_OUTPUT