diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 3 insertions, 8 deletions
@@ -12,10 +12,10 @@ install_requirements = [ # We still need to use pt-2 unless pt-3 released on Fedora32 # see: https://github.com/dbcli/pgcli/pull/1197 "prompt_toolkit>=2.0.6,<4.0.0", - "psycopg >= 3.0.14", - "sqlparse >=0.3.0,<0.5", + "psycopg >= 3.0.14; sys_platform != 'win32'", + "psycopg-binary >= 3.0.14; sys_platform == 'win32'", + "sqlparse >=0.3.0,<0.6", "configobj >= 5.0.6", - "pendulum>=2.1.0", "cli_helpers[styles] >= 2.2.1", ] @@ -27,11 +27,6 @@ install_requirements = [ if platform.system() != "Windows" and not platform.system().startswith("CYGWIN"): install_requirements.append("setproctitle >= 1.1.9") -# Windows will require the binary psycopg to run pgcli -if platform.system() == "Windows": - install_requirements.append("psycopg-binary >= 3.0.14") - - setup( name="pgcli", author="Pgcli Core Team", |