summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ef70aa6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=port-for
+export PYBUILD_SYSTEM=pyproject
+
+%:
+ dh ${@} --buildsystem=pybuild --with python3
+
+override_dh_auto_install:
+ dh_auto_install
+
+override_dh_auto_test:
+ # disabled
+
+ mkdir -p debian/python3-$(PYBUILD_NAME)/usr/share/doc/python3-$(PYBUILD_NAME)
+ cp README.rst debian/python3-$(PYBUILD_NAME)/usr/share/doc/python3-$(PYBUILD_NAME)/README