summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
commit311bcfc6b3acdd6fd152798c7f287ddf74fa2a98 (patch)
tree0ec307299b1dada3701e42f4ca6eda57d708261e /Makefile
parentInitial commit. (diff)
downloadpostgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.tar.xz
postgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.zip
Adding upstream version 15.4.upstream/15.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c66fb30
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,47 @@
+# The PostgreSQL make files exploit features of GNU make that other
+# makes do not have. Because it is a common mistake for users to try
+# to build Postgres with a different make, we have this make file
+# that, as a service, will look for a GNU make and invoke it, or show
+# an error message if none could be found.
+
+# If the user were using GNU make now, this file would not get used
+# because GNU make uses a make file named "GNUmakefile" in preference
+# to "Makefile" if it exists. PostgreSQL is shipped with a
+# "GNUmakefile". If the user hasn't run the configure script yet, the
+# GNUmakefile won't exist yet, so we catch that case as well.
+
+
+# AIX make defaults to building *every* target of the first rule. Start with
+# a single-target, empty rule to make the other targets non-default.
+all:
+
+all check install installdirs installcheck installcheck-parallel uninstall clean distclean maintainer-clean dist distcheck world check-world install-world installcheck-world:
+ @if [ ! -f GNUmakefile ] ; then \
+ if [ -f INSTALL ] ; then \
+ INSTRUCTIONS="INSTALL"; \
+ else \
+ INSTRUCTIONS="README.git"; \
+ fi; \
+ echo "You need to run the 'configure' program first. See the file"; \
+ echo "'$$INSTRUCTIONS' for installation instructions, or visit: " ; \
+ echo "<https://www.postgresql.org/docs/devel/installation.html>" ; \
+ false ; \
+ fi
+ @IFS=':' ; \
+ for dir in $$PATH; do \
+ for prog in gmake gnumake make; do \
+ if [ -f $$dir/$$prog ] && ( $$dir/$$prog -f /dev/null --version 2>/dev/null | grep GNU >/dev/null 2>&1 ) ; then \
+ GMAKE=$$dir/$$prog; \
+ break 2; \
+ fi; \
+ done; \
+ done; \
+ \
+ if [ x"$${GMAKE+set}" = xset ]; then \
+ echo "Using GNU make found at $${GMAKE}"; \
+ unset MAKELEVEL; \
+ $${GMAKE} $@ ; \
+ else \
+ echo "You must use GNU make to build PostgreSQL." ; \
+ false; \
+ fi