summaryrefslogtreecommitdiffstats
path: root/contrib/citext/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
commit311bcfc6b3acdd6fd152798c7f287ddf74fa2a98 (patch)
tree0ec307299b1dada3701e42f4ca6eda57d708261e /contrib/citext/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.tar.xz
postgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.zip
Adding upstream version 15.4.upstream/15.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/citext/Makefile')
-rw-r--r--contrib/citext/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/contrib/citext/Makefile b/contrib/citext/Makefile
new file mode 100644
index 0000000..35db6ea
--- /dev/null
+++ b/contrib/citext/Makefile
@@ -0,0 +1,25 @@
+# contrib/citext/Makefile
+
+MODULES = citext
+
+EXTENSION = citext
+DATA = citext--1.4.sql \
+ citext--1.5--1.6.sql \
+ citext--1.4--1.5.sql \
+ citext--1.3--1.4.sql \
+ citext--1.2--1.3.sql citext--1.1--1.2.sql \
+ citext--1.0--1.1.sql
+PGFILEDESC = "citext - case-insensitive character string data type"
+
+REGRESS = create_index_acl citext citext_utf8
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/citext
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif