summaryrefslogtreecommitdiffstats
path: root/src/bin/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
commit311bcfc6b3acdd6fd152798c7f287ddf74fa2a98 (patch)
tree0ec307299b1dada3701e42f4ca6eda57d708261e /src/bin/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-upstream.tar.xz
postgresql-15-upstream.zip
Adding upstream version 15.4.upstream/15.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/Makefile')
-rw-r--r--src/bin/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/bin/Makefile b/src/bin/Makefile
new file mode 100644
index 0000000..7f9dde9
--- /dev/null
+++ b/src/bin/Makefile
@@ -0,0 +1,44 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/bin (client programs)
+#
+# Portions Copyright (c) 1996-2022, PostgreSQL Global Development Group
+# Portions Copyright (c) 1994, Regents of the University of California
+#
+# src/bin/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/bin
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = \
+ initdb \
+ pg_amcheck \
+ pg_archivecleanup \
+ pg_basebackup \
+ pg_checksums \
+ pg_config \
+ pg_controldata \
+ pg_ctl \
+ pg_dump \
+ pg_resetwal \
+ pg_rewind \
+ pg_test_fsync \
+ pg_test_timing \
+ pg_upgrade \
+ pg_verifybackup \
+ pg_waldump \
+ pgbench \
+ psql \
+ scripts
+
+ifeq ($(PORTNAME), win32)
+SUBDIRS += pgevent
+else
+ALWAYS_SUBDIRS += pgevent
+endif
+
+$(recurse)
+$(recurse_always)