summaryrefslogtreecommitdiffstats
path: root/src/bin/pg_config/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
commit311bcfc6b3acdd6fd152798c7f287ddf74fa2a98 (patch)
tree0ec307299b1dada3701e42f4ca6eda57d708261e /src/bin/pg_config/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.tar.xz
postgresql-15-311bcfc6b3acdd6fd152798c7f287ddf74fa2a98.zip
Adding upstream version 15.4.upstream/15.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/pg_config/Makefile')
-rw-r--r--src/bin/pg_config/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/bin/pg_config/Makefile b/src/bin/pg_config/Makefile
new file mode 100644
index 0000000..c599f88
--- /dev/null
+++ b/src/bin/pg_config/Makefile
@@ -0,0 +1,44 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/bin/pg_config
+#
+# Copyright (c) 1998-2022, PostgreSQL Global Development Group
+#
+# src/bin/pg_config/Makefile
+#
+#-------------------------------------------------------------------------
+
+PGFILEDESC = "pg_config - report configuration information"
+PGAPPICON=win32
+
+subdir = src/bin/pg_config
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+OBJS = \
+ $(WIN32RES) \
+ pg_config.o
+
+all: pg_config
+
+pg_config: $(OBJS) | submake-libpgport
+ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
+
+install: all installdirs
+ $(INSTALL_SCRIPT) pg_config$(X) '$(DESTDIR)$(bindir)/pg_config$(X)'
+
+installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(bindir)'
+
+uninstall:
+ rm -f '$(DESTDIR)$(bindir)/pg_config$(X)'
+
+clean distclean maintainer-clean:
+ rm -f pg_config$(X) $(OBJS)
+ rm -rf tmp_check
+
+check:
+ $(prove_check)
+
+installcheck:
+ $(prove_installcheck)