summaryrefslogtreecommitdiffstats
path: root/contrib/fuzzystrmatch/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /contrib/fuzzystrmatch/Makefile
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/fuzzystrmatch/Makefile')
-rw-r--r--contrib/fuzzystrmatch/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/contrib/fuzzystrmatch/Makefile b/contrib/fuzzystrmatch/Makefile
new file mode 100644
index 0000000..e68bc0e
--- /dev/null
+++ b/contrib/fuzzystrmatch/Makefile
@@ -0,0 +1,40 @@
+# contrib/fuzzystrmatch/Makefile
+
+MODULE_big = fuzzystrmatch
+OBJS = \
+ $(WIN32RES) \
+ daitch_mokotoff.o \
+ dmetaphone.o \
+ fuzzystrmatch.o
+
+EXTENSION = fuzzystrmatch
+DATA = fuzzystrmatch--1.1.sql fuzzystrmatch--1.1--1.2.sql \
+ fuzzystrmatch--1.0--1.1.sql
+
+PGFILEDESC = "fuzzystrmatch - similarities and distance between strings"
+
+REGRESS = fuzzystrmatch fuzzystrmatch_utf8
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/fuzzystrmatch
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif
+
+# Force this dependency to be known even without dependency info built:
+daitch_mokotoff.o: daitch_mokotoff.h
+
+daitch_mokotoff.h: daitch_mokotoff_header.pl
+ $(PERL) $< $@
+
+# daitch_mokotoff.h is included in tarballs, so it has to be made by
+# "distprep" and not cleaned except by "maintainer-clean".
+distprep: daitch_mokotoff.h
+
+maintainer-clean:
+ rm -f daitch_mokotoff.h